aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-SVN-Web
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-07-20 10:33:02 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-07-20 10:33:02 +0000
commit1a45b56f60144f5907f36b5c82f29e12345d0c25 (patch)
treedd16dc989746f9c0b487d3678dd4f419ce21b6ce /devel/p5-SVN-Web
parent6a31271e310366caee0f843372c373f5b5c5ae51 (diff)
downloadports-1a45b56f60144f5907f36b5c82f29e12345d0c25.tar.gz
ports-1a45b56f60144f5907f36b5c82f29e12345d0c25.zip
Notes
Diffstat (limited to 'devel/p5-SVN-Web')
-rw-r--r--devel/p5-SVN-Web/Makefile14
-rw-r--r--devel/p5-SVN-Web/files/patch-Log.pm22
-rw-r--r--devel/p5-SVN-Web/files/patch-Revision.pm11
-rw-r--r--devel/p5-SVN-Web/files/patch-View.pm14
-rw-r--r--devel/p5-SVN-Web/files/patch-action.pm14
5 files changed, 68 insertions, 7 deletions
diff --git a/devel/p5-SVN-Web/Makefile b/devel/p5-SVN-Web/Makefile
index 2fbf679af6f6..75ca5744a276 100644
--- a/devel/p5-SVN-Web/Makefile
+++ b/devel/p5-SVN-Web/Makefile
@@ -7,7 +7,7 @@
PORTNAME= SVN-Web
PORTVERSION= 0.53
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -61,12 +61,6 @@ MAN3= SVN::Web.3 \
SVN::Web::X.3 \
SVN::Web::action.3
-post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/svnweb-install ${PREFIX}/bin
- @${ECHO}
- @${CAT} ${PKGMESSAGE}
- @${ECHO}
-
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500703
@@ -74,4 +68,10 @@ BUILD_DEPENDS+= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
RUN_DEPENDS+= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
.endif
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/svnweb-install ${PREFIX}/bin
+ @${ECHO}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO}
+
.include <bsd.port.post.mk>
diff --git a/devel/p5-SVN-Web/files/patch-Log.pm b/devel/p5-SVN-Web/files/patch-Log.pm
new file mode 100644
index 000000000000..466eb69055cd
--- /dev/null
+++ b/devel/p5-SVN-Web/files/patch-Log.pm
@@ -0,0 +1,22 @@
+--- lib/SVN/Web/Log.pm.org 2008-07-17 11:23:59.000000000 +0900
++++ lib/SVN/Web/Log.pm 2008-07-17 11:27:14.000000000 +0900
+@@ -214,7 +214,10 @@
+ # entries then we're on the last page.
+ #
+ # If we're not on the last page then pop off the extra log entry
+- $ra->get_log([$path], $rev, 1, $limit + 1, 1, 1,
++ my $path_getlog = $path;
++ if ($path_getlog eq "/") {$path_getlog = "";}
++ $path_getlog =~ s/^\///;
++ $ra->get_log([$path_getlog], $rev, 1, $limit + 1, 1, 1,
+ sub { $self->_log(@_) });
+
+ $at_oldest = @{ $self->{REVS} } <= $limit;
+@@ -222,6 +225,7 @@
+ pop @{ $self->{REVS} } unless $at_oldest;
+ } else {
+ # We must be displaying to the oldest rev, so no paging required
++ if($path eq "/") {$path = "";}
+ $ra->get_log([$path], $rev, 1, $limit, 1, 1,
+ sub { $self->_log(@_) });
+
diff --git a/devel/p5-SVN-Web/files/patch-Revision.pm b/devel/p5-SVN-Web/files/patch-Revision.pm
new file mode 100644
index 000000000000..6af094322762
--- /dev/null
+++ b/devel/p5-SVN-Web/files/patch-Revision.pm
@@ -0,0 +1,11 @@
+--- lib/SVN/Web/Revision.pm.org 2008-07-17 11:24:07.000000000 +0900
++++ lib/SVN/Web/Revision.pm 2008-07-17 11:24:50.000000000 +0900
+@@ -211,7 +211,7 @@
+ )
+ if $rev > $yrev;
+
+- $ra->get_log(['/'], $rev, $rev, 1, 1, 1,
++ $ra->get_log([''], $rev, $rev, 1, 1, 1,
+ sub { $self->{REV} = $self->_log(@_) });
+
+ $self->_resolve_changed_paths();
diff --git a/devel/p5-SVN-Web/files/patch-View.pm b/devel/p5-SVN-Web/files/patch-View.pm
new file mode 100644
index 000000000000..9662d261e8f5
--- /dev/null
+++ b/devel/p5-SVN-Web/files/patch-View.pm
@@ -0,0 +1,14 @@
+--- lib/SVN/Web/View.pm.org 2008-07-17 11:24:12.000000000 +0900
++++ lib/SVN/Web/View.pm 2008-07-17 11:24:53.000000000 +0900
+@@ -134,7 +134,10 @@
+ my $rev = $act_rev;
+
+ # Get the log for this revision of the file
+- $ra->get_log([$path], $rev, $rev, 1, 1, 1,
++ my $path_getlog = $path;
++ if ($path_getlog eq "/") {$path_getlog = "";}
++ $path_getlog =~ s/^\///;
++ $ra->get_log([$path_getlog], $rev, $rev, 1, 1, 1,
+ sub { $self->{REV} = $self->_log(@_) });
+
+ # Get the text for this revision of the file
diff --git a/devel/p5-SVN-Web/files/patch-action.pm b/devel/p5-SVN-Web/files/patch-action.pm
new file mode 100644
index 000000000000..0b45cf0879b1
--- /dev/null
+++ b/devel/p5-SVN-Web/files/patch-action.pm
@@ -0,0 +1,14 @@
+--- lib/SVN/Web/action.pm.org 2008-07-17 11:24:18.000000000 +0900
++++ lib/SVN/Web/action.pm 2008-07-17 11:24:57.000000000 +0900
+@@ -241,7 +241,10 @@
+ my $ra = $self->{repos}{ra};
+
+ my @log_result;
+- $ra->get_log([$path], $rev, 1, 1, 0, 1,
++ my $path_getlog = $path;
++ if ($path_getlog eq "/") {$path_getlog = "";}
++ $path_getlog =~ s/^\///;
++ $ra->get_log([$path_getlog], $rev, 1, 1, 0, 1,
+ sub { @log_result = @_; });
+
+ return @log_result if wantarray();