aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-SVN-Web
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-03-16 16:55:26 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-03-16 16:55:26 +0000
commitb9e620e41d7b2f35bb4329e406ea531ef93727aa (patch)
tree23f9448088faca3eb320e26aade22b31ed6763dd /devel/p5-SVN-Web
parenta8f5e9a818394ba446b8f19d0f8d797c0f571813 (diff)
downloadports-b9e620e41d7b2f35bb4329e406ea531ef93727aa.tar.gz
ports-b9e620e41d7b2f35bb4329e406ea531ef93727aa.zip
Notes
Diffstat (limited to 'devel/p5-SVN-Web')
-rw-r--r--devel/p5-SVN-Web/Makefile31
-rw-r--r--devel/p5-SVN-Web/distinfo1
-rw-r--r--devel/p5-SVN-Web/pkg-descr7
-rw-r--r--devel/p5-SVN-Web/pkg-plist19
4 files changed, 58 insertions, 0 deletions
diff --git a/devel/p5-SVN-Web/Makefile b/devel/p5-SVN-Web/Makefile
new file mode 100644
index 000000000000..9ee13a2a1b1d
--- /dev/null
+++ b/devel/p5-SVN-Web/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: devel/p5-SVN-Web
+# Date created: Feb 21 2004
+# Whom: CPANPLUS User <cpanplus@example.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SVN-Web
+PORTVERSION= 0.36
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/C/CL/CLKAO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= autrijus@autrijus.org
+COMMENT= Subversion repository web frontend
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
+ ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/subversion-perl \
+ ${SITE_PERL}/Text/Diff.pm:${PORTSDIR}/textproc/p5-Text-Diff \
+ ${SITE_PERL}/XML/RSS.pm:${PORTSDIR}/textproc/p5-XML-RSS \
+ ${SITE_PERL}/Locale/Maketext/Lexicon.pm:${PORTSDIR}/devel/p5-Locale-Maketext-Lexicon \
+ ${SITE_PERL}/Locale/Maketext/Simple.pm:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
+ ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= SVN::Web.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-SVN-Web/distinfo b/devel/p5-SVN-Web/distinfo
new file mode 100644
index 000000000000..914f679ff8c5
--- /dev/null
+++ b/devel/p5-SVN-Web/distinfo
@@ -0,0 +1 @@
+MD5 (SVN-Web-0.36.tar.gz) = 1cb001b88c9dcfffb0818321feca668d
diff --git a/devel/p5-SVN-Web/pkg-descr b/devel/p5-SVN-Web/pkg-descr
new file mode 100644
index 000000000000..22f817d473e8
--- /dev/null
+++ b/devel/p5-SVN-Web/pkg-descr
@@ -0,0 +1,7 @@
+SVN::Web provides a web interface to subversion repositories. You can
+browse the tree, view history of a directory or a file, see what's
+changed in a specific revision, track changes with RSS, and also view
+diff.
+
+SVN::Web also tracks the branching feature (node copy) of subversion,
+so you can easily see the relationship between branches.
diff --git a/devel/p5-SVN-Web/pkg-plist b/devel/p5-SVN-Web/pkg-plist
new file mode 100644
index 000000000000..f586722a580c
--- /dev/null
+++ b/devel/p5-SVN-Web/pkg-plist
@@ -0,0 +1,19 @@
+bin/svnweb-install
+%%SITE_PERL%%/SVN/Web.pm
+%%SITE_PERL%%/SVN/Web/Branch.pm
+%%SITE_PERL%%/SVN/Web/Browse.pm
+%%SITE_PERL%%/SVN/Web/Checkout.pm
+%%SITE_PERL%%/SVN/Web/Diff.pm
+%%SITE_PERL%%/SVN/Web/List.pm
+%%SITE_PERL%%/SVN/Web/Log.pm
+%%SITE_PERL%%/SVN/Web/RSS.pm
+%%SITE_PERL%%/SVN/Web/Revision.pm
+%%SITE_PERL%%/SVN/Web/Template.pm
+%%SITE_PERL%%/SVN/Web/I18N/en.po
+%%SITE_PERL%%/SVN/Web/I18N/zh_cn.po
+%%SITE_PERL%%/SVN/Web/I18N/zh_tw.po
+@dirrm %%SITE_PERL%%/SVN/Web/I18N
+@dirrm %%SITE_PERL%%/SVN/Web
+@unexec rmdir %D/%%SITE_PERL%%/SVN 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/Web 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN 2>/dev/null || true