aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Scalar-Defer
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-21 16:27:11 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-21 16:27:11 +0000
commitddc13af870a25a859d7943b64093acdf2b3a8cde (patch)
tree38d13f75ca84c8dc71fb034bc52a2866447d6edd /devel/p5-Scalar-Defer
parentd8aa2136c664a4a13ccc5c395346e3f68187f1fa (diff)
downloadports-ddc13af870a25a859d7943b64093acdf2b3a8cde.tar.gz
ports-ddc13af870a25a859d7943b64093acdf2b3a8cde.zip
Notes
Diffstat (limited to 'devel/p5-Scalar-Defer')
-rw-r--r--devel/p5-Scalar-Defer/Makefile25
-rw-r--r--devel/p5-Scalar-Defer/distinfo3
-rw-r--r--devel/p5-Scalar-Defer/pkg-descr8
-rw-r--r--devel/p5-Scalar-Defer/pkg-plist6
4 files changed, 42 insertions, 0 deletions
diff --git a/devel/p5-Scalar-Defer/Makefile b/devel/p5-Scalar-Defer/Makefile
new file mode 100644
index 000000000000..a3f067b0062a
--- /dev/null
+++ b/devel/p5-Scalar-Defer/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Scalar-Defer
+# Date created: 2006-07-20
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Scalar-Defer
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Scalar
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Calculate values on demand
+
+RUN_DEPENDS= ${SITE_PERL}/Class/InsideOut.pm:${PORTSDIR}/devel/p5-Class-InsideOut \
+ ${SITE_PERL}/Exporter/Lite.pm:${PORTSDIR}/devel/p5-Exporter-Lite
+
+PERL_CONFIGURE= yes
+
+MAN3= Scalar::Defer.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Scalar-Defer/distinfo b/devel/p5-Scalar-Defer/distinfo
new file mode 100644
index 000000000000..35da4422e934
--- /dev/null
+++ b/devel/p5-Scalar-Defer/distinfo
@@ -0,0 +1,3 @@
+MD5 (Scalar-Defer-0.04.tar.gz) = ef8f621cf4a73a6c91855262646c9153
+SHA256 (Scalar-Defer-0.04.tar.gz) = 6bc596ee5daa3215fa1392bb21d433f39c797a5990ea5e26d5d285a8c16f5025
+SIZE (Scalar-Defer-0.04.tar.gz) = 24951
diff --git a/devel/p5-Scalar-Defer/pkg-descr b/devel/p5-Scalar-Defer/pkg-descr
new file mode 100644
index 000000000000..3d802cadc5d8
--- /dev/null
+++ b/devel/p5-Scalar-Defer/pkg-descr
@@ -0,0 +1,8 @@
+Unlike the tie-based Data::Lazy, this module operates on values, not
+variables. Therefore, assigning into $dv and $lv above will simply
+replace the value, instead of triggering a STORE method call.
+
+Also, thanks to the overload-based implementation, this module is
+about 2x faster than Data::Lazy.
+
+WWW: http://search.cpan.org/dist/Scalar-Defer/
diff --git a/devel/p5-Scalar-Defer/pkg-plist b/devel/p5-Scalar-Defer/pkg-plist
new file mode 100644
index 000000000000..f8956bea9c06
--- /dev/null
+++ b/devel/p5-Scalar-Defer/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Scalar/Defer/.packlist
+%%SITE_PERL%%/Scalar/Defer.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Scalar/Defer
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Scalar
+@dirrmtry %%SITE_PERL%%/Scalar