aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Scalar-Listify
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-02-16 10:29:36 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-02-16 10:29:36 +0000
commit52797b925c16d7e430dbd29b02f2a90739a74c87 (patch)
tree085530f500f20f8ca3a7f8e123ef266672438702 /devel/p5-Scalar-Listify
parent7857f37709e8057461e725394f2cb5e7314fcb15 (diff)
downloadports-52797b925c16d7e430dbd29b02f2a90739a74c87.tar.gz
ports-52797b925c16d7e430dbd29b02f2a90739a74c87.zip
Notes
Diffstat (limited to 'devel/p5-Scalar-Listify')
-rw-r--r--devel/p5-Scalar-Listify/Makefile22
-rw-r--r--devel/p5-Scalar-Listify/distinfo3
-rw-r--r--devel/p5-Scalar-Listify/pkg-descr13
-rw-r--r--devel/p5-Scalar-Listify/pkg-plist5
4 files changed, 43 insertions, 0 deletions
diff --git a/devel/p5-Scalar-Listify/Makefile b/devel/p5-Scalar-Listify/Makefile
new file mode 100644
index 000000000000..fd2f2e526794
--- /dev/null
+++ b/devel/p5-Scalar-Listify/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Scalar-Listify
+# Date created: 2007/02/14
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Scalar-Listify
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Scalar
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Poduces an array(ref)? from a scalar value or array ref
+
+MAN3= Scalar::Listify.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Scalar-Listify/distinfo b/devel/p5-Scalar-Listify/distinfo
new file mode 100644
index 000000000000..abfffbde422d
--- /dev/null
+++ b/devel/p5-Scalar-Listify/distinfo
@@ -0,0 +1,3 @@
+MD5 (Scalar-Listify-0.02.tar.gz) = 3a61ad269f70b36aee189d068392d04a
+SHA256 (Scalar-Listify-0.02.tar.gz) = 5718cce30292645f8ce53e86dc0e9f82fc9bd4c12e51194f3cca32d7fb7254fc
+SIZE (Scalar-Listify-0.02.tar.gz) = 2243
diff --git a/devel/p5-Scalar-Listify/pkg-descr b/devel/p5-Scalar-Listify/pkg-descr
new file mode 100644
index 000000000000..8b930fa0a823
--- /dev/null
+++ b/devel/p5-Scalar-Listify/pkg-descr
@@ -0,0 +1,13 @@
+A lot of Perl code ends up with scalars having either a single scalar value
+or a reference to an array of scalar values. In order to handle the two
+conditions, one must check for what is in the scalar value before getting on
+with one's task. Ie:
+
+ $text_scalar = 'text';
+ $aref_scalar = [ 1.. 5 ];
+
+ print ref($text_scalar) ? (join ':', @$text_scalar) : $text_scalar;
+
+And this module is designed to address just that!
+
+WWW: http://search.cpan.org/dist/Scalar-Listify/
diff --git a/devel/p5-Scalar-Listify/pkg-plist b/devel/p5-Scalar-Listify/pkg-plist
new file mode 100644
index 000000000000..685530cadfe3
--- /dev/null
+++ b/devel/p5-Scalar-Listify/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Scalar/Listify/.packlist
+%%SITE_PERL%%/Scalar/Listify.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Scalar/Listify
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Scalar
+@dirrmtry %%SITE_PERL%%/Scalar