aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Scope-Guard
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-30 22:09:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-30 22:09:16 +0000
commite9378167b7f9337f2abef2c520a64e5b67901ba2 (patch)
tree4d17afb7f26f3f13ca90beccbf157c1522b85b72 /devel/p5-Scope-Guard
parent1626ad0f0eb84333eef6c4e3aadbedd4402d1b83 (diff)
downloadports-e9378167b7f9337f2abef2c520a64e5b67901ba2.tar.gz
ports-e9378167b7f9337f2abef2c520a64e5b67901ba2.zip
Notes
Diffstat (limited to 'devel/p5-Scope-Guard')
-rw-r--r--devel/p5-Scope-Guard/Makefile29
-rw-r--r--devel/p5-Scope-Guard/distinfo3
-rw-r--r--devel/p5-Scope-Guard/pkg-descr10
-rw-r--r--devel/p5-Scope-Guard/pkg-plist6
4 files changed, 48 insertions, 0 deletions
diff --git a/devel/p5-Scope-Guard/Makefile b/devel/p5-Scope-Guard/Makefile
new file mode 100644
index 000000000000..6e164b5b2908
--- /dev/null
+++ b/devel/p5-Scope-Guard/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Scope-Guard
+# Date created: 29 December 2006
+# Whom: Craig Manley
+#
+# $FreeBSD$
+#
+
+PORTNAME= Scope-Guard
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+#MASTER_SITE_SUBDIR= Scope
+MASTER_SITE_SUBDIR= ../by-authors/id/C/CH/CHOCOLATE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cmanley@xs4all.nl
+COMMENT= Lexically scoped resource management
+
+PERL_CONFIGURE= yes
+
+MAN3= Scope::Guard.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Scope-Guard/distinfo b/devel/p5-Scope-Guard/distinfo
new file mode 100644
index 000000000000..471e521d0be9
--- /dev/null
+++ b/devel/p5-Scope-Guard/distinfo
@@ -0,0 +1,3 @@
+MD5 (Scope-Guard-0.02.tar.gz) = 6c5da688e7dbe762147fd1441a747b25
+SHA256 (Scope-Guard-0.02.tar.gz) = 562ac7867c68f488b63f6ef88230b7b341dc69d0a91d31b1bdc672b7bf1f3d10
+SIZE (Scope-Guard-0.02.tar.gz) = 2736
diff --git a/devel/p5-Scope-Guard/pkg-descr b/devel/p5-Scope-Guard/pkg-descr
new file mode 100644
index 000000000000..d6b5639f853d
--- /dev/null
+++ b/devel/p5-Scope-Guard/pkg-descr
@@ -0,0 +1,10 @@
+This module provides a convenient way to perform cleanup or other forms of
+resource management at the end of a scope. It is particularly useful when
+dealing with exceptions: the Scope::Guard constructor takes a reference to a
+subroutine that is guaranteed to be called even if the thread of execution is
+aborted prematurely. This effectively allows lexically-scoped "promises" to be
+made that are automatically honoured by perl's garbage collector.
+
+For more info, see: http://www.cuj.com/documents/s=8000/cujcexp1812alexandr/
+
+WWW: http://search.cpan.org/dist/Scope-Guard/
diff --git a/devel/p5-Scope-Guard/pkg-plist b/devel/p5-Scope-Guard/pkg-plist
new file mode 100644
index 000000000000..a621ae8262a4
--- /dev/null
+++ b/devel/p5-Scope-Guard/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Scope/Guard/.packlist
+%%SITE_PERL%%/Scope/Guard.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Scope/Guard
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Scope
+@dirrmtry %%SITE_PERL%%/Scope