aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Set-ConsistentHash
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2008-01-24 02:47:24 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2008-01-24 02:47:24 +0000
commit2409cfe44d675723f53f6627dbf51c9b5ecb3b59 (patch)
treefba90a80a44fb3add099258fe90f2f563269c9b5 /devel/p5-Set-ConsistentHash
parentd86e68157a0baf62342b05d4bd07f1a7fbdd1915 (diff)
Notes
Diffstat (limited to 'devel/p5-Set-ConsistentHash')
-rw-r--r--devel/p5-Set-ConsistentHash/Makefile24
-rw-r--r--devel/p5-Set-ConsistentHash/distinfo3
-rw-r--r--devel/p5-Set-ConsistentHash/pkg-descr11
-rw-r--r--devel/p5-Set-ConsistentHash/pkg-plist6
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/p5-Set-ConsistentHash/Makefile b/devel/p5-Set-ConsistentHash/Makefile
new file mode 100644
index 000000000000..4339d82e419a
--- /dev/null
+++ b/devel/p5-Set-ConsistentHash/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Set-ConsistentHash
+# Date created: 2008-01-12
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Set-ConsistentHash
+PORTVERSION= 0.91
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Set
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Library for doing consistent hashing
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+
+PERL_CONFIGURE= yes
+
+MAN3= Set::ConsistentHash.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Set-ConsistentHash/distinfo b/devel/p5-Set-ConsistentHash/distinfo
new file mode 100644
index 000000000000..efde76cd5e3a
--- /dev/null
+++ b/devel/p5-Set-ConsistentHash/distinfo
@@ -0,0 +1,3 @@
+MD5 (Set-ConsistentHash-0.91.tar.gz) = 9ffc6a8c4d525e5cf36e5c3f3a442587
+SHA256 (Set-ConsistentHash-0.91.tar.gz) = 990f0c06e2a5b19993cd1281ee71eccd278f6c517b05a3aba918a702e9ce31f9
+SIZE (Set-ConsistentHash-0.91.tar.gz) = 4980
diff --git a/devel/p5-Set-ConsistentHash/pkg-descr b/devel/p5-Set-ConsistentHash/pkg-descr
new file mode 100644
index 000000000000..2092ae0eb661
--- /dev/null
+++ b/devel/p5-Set-ConsistentHash/pkg-descr
@@ -0,0 +1,11 @@
+Consistent hashing is a scheme that provides hash table functionality
+in a way that the addition or removal of one slot does not
+significantly change the mapping of keys to slots. In contrast, in
+most traditional hash tables, a change in the number of array slots
+causes nearly all keys to be remapped.
+
+Consistent hashing was introduced in 1997 as a way of distributing
+requests among a changing population of web servers. More recently, it
+and similar techniques have been employed in distributed hash tables.
+
+WWW: http://search.cpan.org/dist/Set-ConsistentHash/
diff --git a/devel/p5-Set-ConsistentHash/pkg-plist b/devel/p5-Set-ConsistentHash/pkg-plist
new file mode 100644
index 000000000000..781c413b4012
--- /dev/null
+++ b/devel/p5-Set-ConsistentHash/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Set/ConsistentHash/.packlist
+%%SITE_PERL%%/Set/ConsistentHash.pm
+@dirrmtry %%SITE_PERL%%/Set
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Set/ConsistentHash
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Set