aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Shell-Base/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2004-02-24 11:03:26 +0000
committerErwin Lansing <erwin@FreeBSD.org>2004-02-24 11:03:26 +0000
commitb8289656c4a7d6d95395228beea5037191522d90 (patch)
treed281251e3ad51d493091eaf0be2fd8ad18f18cb2 /devel/p5-Shell-Base/Makefile
parentafbbe75052c80659159ec7130cb5209e83454de5 (diff)
downloadports-b8289656c4a7d6d95395228beea5037191522d90.tar.gz
ports-b8289656c4a7d6d95395228beea5037191522d90.zip
Notes
Diffstat (limited to 'devel/p5-Shell-Base/Makefile')
-rw-r--r--devel/p5-Shell-Base/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/devel/p5-Shell-Base/Makefile b/devel/p5-Shell-Base/Makefile
new file mode 100644
index 000000000000..2ddb756d7697
--- /dev/null
+++ b/devel/p5-Shell-Base/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Shell::Base
+# Date created: Sat Jan 31 10:41:28 EST 2004
+# Whom: Christopher Nehren <apeiron@comcast.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Shell-Base
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Shell
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= apeiron@comcast.net
+COMMENT= Perl module implementing a simple command shell
+
+BUILD_DEPENDS= ${SITE_PERL}/mach/Term/Size.pm:${PORTSDIR}/devel/p5-Term-Size \
+ ${SITE_PERL}/Text/Shellwords.pm:${PORTSDIR}/textproc/p5-Text-Shellwords
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Shell::Base.3
+
+.include <bsd.port.mk>