aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Spiffy
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-07-16 02:22:10 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-07-16 02:22:10 +0000
commit03942b2d346bc92844358fec6d37683c5e889c32 (patch)
tree6047ea7dff441ce42fdd21bb6f6ab113e5158980 /devel/p5-Spiffy
parent31f57dea12fd180140de1ba3e960da81cf07d863 (diff)
downloadports-03942b2d346bc92844358fec6d37683c5e889c32.tar.gz
ports-03942b2d346bc92844358fec6d37683c5e889c32.zip
Notes
Diffstat (limited to 'devel/p5-Spiffy')
-rw-r--r--devel/p5-Spiffy/Makefile32
-rw-r--r--devel/p5-Spiffy/distinfo2
-rw-r--r--devel/p5-Spiffy/pkg-descr9
-rw-r--r--devel/p5-Spiffy/pkg-plist3
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/p5-Spiffy/Makefile b/devel/p5-Spiffy/Makefile
new file mode 100644
index 000000000000..2ca09975d63f
--- /dev/null
+++ b/devel/p5-Spiffy/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Spiffy
+# Date created: 15 Jul 2004
+# Whom: Elvis Chiang <elvis@sslab.cs.ccu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Spiffy
+PORTVERSION= 0.18
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/I/IN/INGY/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Spiffy Perl Interface Framework For You
+
+PERL_CONFIGURE= yes
+
+MAN3= Spiffy.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Filter/Util/Call.pm:${PORTSDIR}/devel/p5-Filter
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+.endif
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.8.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Spiffy/distinfo b/devel/p5-Spiffy/distinfo
new file mode 100644
index 000000000000..58285cf7264d
--- /dev/null
+++ b/devel/p5-Spiffy/distinfo
@@ -0,0 +1,2 @@
+MD5 (Spiffy-0.18.tar.gz) = a86178288a9c550e4daeacdf6277d165
+SIZE (Spiffy-0.18.tar.gz) = 20206
diff --git a/devel/p5-Spiffy/pkg-descr b/devel/p5-Spiffy/pkg-descr
new file mode 100644
index 000000000000..b30afdbfaada
--- /dev/null
+++ b/devel/p5-Spiffy/pkg-descr
@@ -0,0 +1,9 @@
+IO::All - Spiffy Perl Interface Framework For You
+
+Spiffy" is a framework and methodology for doing object oriented programming
+in Perl. Spiffy combines the best parts of Exporter.pm, base.pm, mixin.pm and
+SUPER.pm into one magic foundation class. It attempts to fix all the nits and
+warts of traditional Perl OO, in a clean, straightforward and
+(perhaps someday) standard way.
+
+WWW: http://search.cpan.org/~ingy/Spiffy-0.18/
diff --git a/devel/p5-Spiffy/pkg-plist b/devel/p5-Spiffy/pkg-plist
new file mode 100644
index 000000000000..401f642fa926
--- /dev/null
+++ b/devel/p5-Spiffy/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Spiffy/.packlist
+%%SITE_PERL%%/Spiffy.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Spiffy