aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Spoon
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2005-04-07 03:51:14 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2005-04-07 03:51:14 +0000
commitd2b5782b4d8f51031782a9a6fe139c0a76143e2b (patch)
treebeba4a98ee077dedf1f992402e72a960c6c24604 /devel/p5-Spoon
parent0ab1ceea8f98611398044909cf2d34b8f2473e21 (diff)
downloadports-d2b5782b4d8f51031782a9a6fe139c0a76143e2b.tar.gz
ports-d2b5782b4d8f51031782a9a6fe139c0a76143e2b.zip
Notes
Diffstat (limited to 'devel/p5-Spoon')
-rw-r--r--devel/p5-Spoon/Makefile2
-rw-r--r--devel/p5-Spoon/distinfo4
-rw-r--r--devel/p5-Spoon/files/patch-Makefile.PL21
-rw-r--r--devel/p5-Spoon/files/patch-inc::Module::Install::Makefile.pm146
4 files changed, 3 insertions, 170 deletions
diff --git a/devel/p5-Spoon/Makefile b/devel/p5-Spoon/Makefile
index b0ffde5d54db..d6c558dcf4f8 100644
--- a/devel/p5-Spoon/Makefile
+++ b/devel/p5-Spoon/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Spoon
-PORTVERSION= 0.22
+PORTVERSION= 0.23
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../../authors/id/I/IN/INGY/
diff --git a/devel/p5-Spoon/distinfo b/devel/p5-Spoon/distinfo
index 5936e912bb0a..ff4362fc1ac0 100644
--- a/devel/p5-Spoon/distinfo
+++ b/devel/p5-Spoon/distinfo
@@ -1,2 +1,2 @@
-MD5 (Spoon-0.22.tar.gz) = 84af7c1a9d25b29b42490e2802ed3009
-SIZE (Spoon-0.22.tar.gz) = 24583
+MD5 (Spoon-0.23.tar.gz) = 96acf017b3aa492e62afb1f826d3d9bd
+SIZE (Spoon-0.23.tar.gz) = 25801
diff --git a/devel/p5-Spoon/files/patch-Makefile.PL b/devel/p5-Spoon/files/patch-Makefile.PL
deleted file mode 100644
index 93f258716c87..000000000000
--- a/devel/p5-Spoon/files/patch-Makefile.PL
+++ /dev/null
@@ -1,21 +0,0 @@
---- Makefile.PL.orig Wed Apr 6 10:07:55 2005
-+++ Makefile.PL Wed Apr 6 10:07:42 2005
-@@ -0,0 +1,18 @@
-+use inc::Module::Install;
-+
-+name('Spoon');
-+author('Brian Ingerson <ingy@cpan.org>');
-+abstract('Out of the Cutlery Drawer');
-+license('perl');
-+version_from('lib/Spoon.pm');
-+
-+requires(qw(
-+ perl 5.6.1
-+ Spiffy 0.22
-+ IO::All 0.32
-+ Template 2.10
-+));
-+
-+clean_files('t/tmp', 't/output');
-+
-+&WriteAll();
diff --git a/devel/p5-Spoon/files/patch-inc::Module::Install::Makefile.pm b/devel/p5-Spoon/files/patch-inc::Module::Install::Makefile.pm
deleted file mode 100644
index e6b1a05fbc91..000000000000
--- a/devel/p5-Spoon/files/patch-inc::Module::Install::Makefile.pm
+++ /dev/null
@@ -1,146 +0,0 @@
---- inc/Module/Install/Makefile.pm.orig Wed Apr 6 10:14:53 2005
-+++ inc/Module/Install/Makefile.pm Wed Apr 6 10:14:36 2005
-@@ -0,0 +1,143 @@
-+#line 1 "inc/Module/Install/Makefile.pm - /usr/local/lib/perl5/site_perl/5.8.6/Module/Install/Makefile.pm"
-+package Module::Install::Makefile;
-+use Module::Install::Base; @ISA = qw(Module::Install::Base);
-+
-+$VERSION = '0.01';
-+
-+use strict 'vars';
-+use vars '$VERSION';
-+
-+use ExtUtils::MakeMaker ();
-+
-+sub Makefile { $_[0] }
-+
-+sub prompt {
-+ shift;
-+ goto &ExtUtils::MakeMaker::prompt;
-+}
-+
-+sub makemaker_args {
-+ my $self = shift;
-+ my $args = ($self->{makemaker_args} ||= {});
-+ %$args = ( %$args, @_ ) if @_;
-+ $args;
-+}
-+
-+sub clean_files {
-+ my $self = shift;
-+ my $clean = $self->makemaker_args->{clean} ||= {};
-+ %$clean = (
-+ %$clean,
-+ FILES => join(" ", grep length, $clean->{FILES}, @_),
-+ );
-+}
-+
-+sub libs {
-+ my $self = shift;
-+ my $libs = ref $_[0] ? shift : [shift];
-+ $self->makemaker_args( LIBS => $libs );
-+}
-+
-+sub inc {
-+ my $self = shift;
-+ $self->makemaker_args( INC => shift );
-+}
-+
-+sub write {
-+ my $self = shift;
-+ die "&Makefile->write() takes no arguments\n" if @_;
-+
-+ my $args = $self->makemaker_args;
-+
-+ $args->{DISTNAME} = $self->name;
-+ $args->{NAME} = $self->module_name || $self->name || $self->determine_NAME($args);
-+ $args->{VERSION} = $self->version || $self->determine_VERSION($args);
-+ $args->{NAME} =~ s/-/::/g;
-+
-+ if ($] >= 5.005) {
-+ $args->{ABSTRACT} = $self->abstract;
-+ $args->{AUTHOR} = $self->author;
-+ }
-+ if ( eval($ExtUtils::MakeMaker::VERSION) >= 6.10 ) {
-+ $args->{NO_META} = 1;
-+ }
-+ if ( eval($ExtUtils::MakeMaker::VERSION) > 6.17 ) {
-+ $args->{SIGN} = 1 if $self->sign;
-+ }
-+ delete $args->{SIGN} unless $self->is_admin;
-+
-+ # merge both kinds of requires into prereq_pm
-+ my $prereq = ($args->{PREREQ_PM} ||= {});
-+ %$prereq = ( %$prereq, map { @$_ } map { @$_ } grep $_,
-+ ($self->build_requires, $self->requires) );
-+
-+ # merge both kinds of requires into prereq_pm
-+ my $dir = ($args->{DIR} ||= []);
-+ if ($self->bundles) {
-+ push @$dir, map "$_->[1]", @{$self->bundles};
-+ delete $prereq->{$_->[0]} for @{$self->bundles};
-+ }
-+
-+ if (my $perl_version = $self->perl_version) {
-+ eval "use $perl_version; 1"
-+ or die "ERROR: perl: Version $] is installed, ".
-+ "but we need version >= $perl_version";
-+ }
-+
-+ my %args = map {($_ => $args->{$_})} grep {defined($args->{$_})} keys %$args;
-+
-+ if ($self->admin->preop) {
-+ $args{dist} = $self->admin->preop;
-+ }
-+
-+ ExtUtils::MakeMaker::WriteMakefile(%args);
-+
-+ $self->fix_up_makefile();
-+}
-+
-+sub fix_up_makefile {
-+ my $self = shift;
-+ my $top_class = ref($self->_top) || '';
-+ my $top_version = $self->_top->VERSION || '';
-+
-+ my $preamble = $self->preamble
-+ ? "# Preamble by $top_class $top_version\n" . $self->preamble
-+ : '';
-+ my $postamble = "# Postamble by $top_class $top_version\n" .
-+ ($self->postamble || '');
-+
-+ open MAKEFILE, '< Makefile' or die $!;
-+ my $makefile = do { local $/; <MAKEFILE> };
-+ close MAKEFILE;
-+
-+ $makefile =~ s/\b(test_harness\(\$\(TEST_VERBOSE\), )/$1'inc', /;
-+ $makefile =~ s/( -I\$\(INST_ARCHLIB\))/ -Iinc$1/g;
-+ $makefile =~ s/( "-I\$\(INST_LIB\)")/ "-Iinc"$1/g;
-+
-+ $makefile =~ s/^(FULLPERL = .*)/$1 -Iinc/m;
-+ $makefile =~ s/^(PERL = .*)/$1 -Iinc/m;
-+
-+ open MAKEFILE, '> Makefile' or die $!;
-+ print MAKEFILE "$preamble$makefile$postamble";
-+ close MAKEFILE;
-+}
-+
-+sub preamble {
-+ my ($self, $text) = @_;
-+ $self->{preamble} = $text . $self->{preamble} if defined $text;
-+ $self->{preamble};
-+}
-+
-+sub postamble {
-+ my ($self, $text) = @_;
-+
-+ $self->{postamble} ||= $self->admin->postamble;
-+ $self->{postamble} .= $text if defined $text;
-+ $self->{postamble}
-+}
-+
-+1;
-+
-+__END__
-+
-+#line 273