aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-String-Diff
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2009-03-29 15:20:38 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2009-03-29 15:20:38 +0000
commit9701d8c97e1deaed28b26bc93ebb13357857c16a (patch)
tree2db207f9f5e6800af7f95112e6599c6fa57f3269 /devel/p5-String-Diff
parent696e62a0c59b5666734beae48df8114ff5166278 (diff)
downloadports-9701d8c97e1deaed28b26bc93ebb13357857c16a.tar.gz
ports-9701d8c97e1deaed28b26bc93ebb13357857c16a.zip
Notes
Diffstat (limited to 'devel/p5-String-Diff')
-rw-r--r--devel/p5-String-Diff/Makefile27
-rw-r--r--devel/p5-String-Diff/distinfo3
-rw-r--r--devel/p5-String-Diff/pkg-descr3
-rw-r--r--devel/p5-String-Diff/pkg-plist5
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/p5-String-Diff/Makefile b/devel/p5-String-Diff/Makefile
new file mode 100644
index 000000000000..badea407f53a
--- /dev/null
+++ b/devel/p5-String-Diff/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: devel/p5-String-Diff
+# Date created: 29 Mar 2009
+# Whom: Lars Balker Rasmussen <lbr@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= String-Diff
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= Simple diff to String
+
+RUN_DEPENDS= p5-Algorithm-Diff>=0:${PORTSDIR}/devel/p5-Algorithm-Diff
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= 5.8.1+
+
+MAN3= String::Diff.3
+
+post-extract:
+ @${PERL} -i.bak -ne 'print unless m,^build_requires,' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/devel/p5-String-Diff/distinfo b/devel/p5-String-Diff/distinfo
new file mode 100644
index 000000000000..fd52e0784bb8
--- /dev/null
+++ b/devel/p5-String-Diff/distinfo
@@ -0,0 +1,3 @@
+MD5 (String-Diff-0.04.tar.gz) = 440bd85674f8602f18a2ab7978f1fa53
+SHA256 (String-Diff-0.04.tar.gz) = b6712f65cb9ab09d0a83c9cf968992031effd1263cdf8b8bcb9f17016e7eb321
+SIZE (String-Diff-0.04.tar.gz) = 40009
diff --git a/devel/p5-String-Diff/pkg-descr b/devel/p5-String-Diff/pkg-descr
new file mode 100644
index 000000000000..5942a72c3687
--- /dev/null
+++ b/devel/p5-String-Diff/pkg-descr
@@ -0,0 +1,3 @@
+Simple diff to String
+
+WWW: http://search.cpan.org/dist/String-Diff/
diff --git a/devel/p5-String-Diff/pkg-plist b/devel/p5-String-Diff/pkg-plist
new file mode 100644
index 000000000000..1ef422ebff75
--- /dev/null
+++ b/devel/p5-String-Diff/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Diff/.packlist
+%%SITE_PERL%%/String/Diff.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Diff
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/String
+@dirrmtry %%SITE_PERL%%/String