aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Sub-Delete
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-21 20:44:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-21 20:44:48 +0000
commit4f9a4470e198218dbffdd01b99a37201ab7ecec4 (patch)
tree07139972d7009e434aa66b4c64ea8f6486aae1dc /devel/p5-Sub-Delete
parent1dc55cf38fa0ea2dd3f7fbb0e2f7152dfa64813c (diff)
downloadports-4f9a4470e198218dbffdd01b99a37201ab7ecec4.tar.gz
ports-4f9a4470e198218dbffdd01b99a37201ab7ecec4.zip
Notes
Diffstat (limited to 'devel/p5-Sub-Delete')
-rw-r--r--devel/p5-Sub-Delete/Makefile24
-rw-r--r--devel/p5-Sub-Delete/distinfo3
-rw-r--r--devel/p5-Sub-Delete/pkg-descr11
-rw-r--r--devel/p5-Sub-Delete/pkg-plist6
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/p5-Sub-Delete/Makefile b/devel/p5-Sub-Delete/Makefile
new file mode 100644
index 000000000000..e8c3a9c4f271
--- /dev/null
+++ b/devel/p5-Sub-Delete/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Sub-Delete
+# Date created: 2008-11-16
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sub-Delete
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Sub
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl module enabling one to delete subroutines
+
+PERL_CONFIGURE= yes
+USE_PERL5= 5.8.3+
+
+MAN3= Sub::Delete.3
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Sub-Delete/distinfo b/devel/p5-Sub-Delete/distinfo
new file mode 100644
index 000000000000..dad8ea8565ac
--- /dev/null
+++ b/devel/p5-Sub-Delete/distinfo
@@ -0,0 +1,3 @@
+MD5 (Sub-Delete-0.02.tar.gz) = 54f2015f0add6cd5f0dbe64ea7056150
+SHA256 (Sub-Delete-0.02.tar.gz) = 3274e766a91873dbcdee5144beb2181df7d9bba9d0b6ab9758b98704bd4e2c07
+SIZE (Sub-Delete-0.02.tar.gz) = 3213
diff --git a/devel/p5-Sub-Delete/pkg-descr b/devel/p5-Sub-Delete/pkg-descr
new file mode 100644
index 000000000000..326211940f75
--- /dev/null
+++ b/devel/p5-Sub-Delete/pkg-descr
@@ -0,0 +1,11 @@
+This module provides one function, delete_sub, that deletes the
+subroutine whose name is passed to it. (To load the module without
+importing the function, write use Sub::Delete();.)
+
+This does more than simply undefine the subroutine in the manner of
+undef &foo, which leaves a stub that can trigger AUTOLOAD (and,
+consequently, won't work for deleting methods). The subroutine is
+completely obliterated from the symbol table (though there may be
+references to it elsewhere, including in compiled code).
+
+WWW: http://search.cpan.org/dist/Sub-Delete/
diff --git a/devel/p5-Sub-Delete/pkg-plist b/devel/p5-Sub-Delete/pkg-plist
new file mode 100644
index 000000000000..e9041c1a62fb
--- /dev/null
+++ b/devel/p5-Sub-Delete/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Delete/.packlist
+%%SITE_PERL%%/Sub/Delete.pm
+@dirrmtry %%SITE_PERL%%/Sub
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Delete
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub