aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Sub-Installer
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2006-01-12 13:09:46 +0000
committerAnton Berezin <tobez@FreeBSD.org>2006-01-12 13:09:46 +0000
commit36181cb6bc390f8fbf65c6eb2ec9a95db78432a7 (patch)
treeb5cb6c16cccc8d9666c29a5ba7f3cf7a6a300960 /devel/p5-Sub-Installer
parent9df4f67be2a3791c2c1f7579283a5cd987fd4ac9 (diff)
downloadports-36181cb6bc390f8fbf65c6eb2ec9a95db78432a7.tar.gz
ports-36181cb6bc390f8fbf65c6eb2ec9a95db78432a7.zip
Notes
Diffstat (limited to 'devel/p5-Sub-Installer')
-rw-r--r--devel/p5-Sub-Installer/Makefile31
-rw-r--r--devel/p5-Sub-Installer/distinfo3
-rw-r--r--devel/p5-Sub-Installer/pkg-descr4
-rw-r--r--devel/p5-Sub-Installer/pkg-plist5
4 files changed, 43 insertions, 0 deletions
diff --git a/devel/p5-Sub-Installer/Makefile b/devel/p5-Sub-Installer/Makefile
new file mode 100644
index 000000000000..67201b1ce0e1
--- /dev/null
+++ b/devel/p5-Sub-Installer/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: devel/p5-Sub-Installer
+# Date created: 12 January 2006
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sub-Installer
+PORTVERSION= 0.0.2
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sub
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Sub::Installer - A clean way to (re)install package subroutines
+
+BUILD_DEPENDS= p5-version>0:${PORTSDIR}/devel/p5-version
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Sub::Installer.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Sub-Installer/distinfo b/devel/p5-Sub-Installer/distinfo
new file mode 100644
index 000000000000..326ec16a0b0d
--- /dev/null
+++ b/devel/p5-Sub-Installer/distinfo
@@ -0,0 +1,3 @@
+MD5 (Sub-Installer-0.0.2.tar.gz) = 16f7d81aaec68f4bb637a81839a9736e
+SHA256 (Sub-Installer-0.0.2.tar.gz) = d4d8a4e5523a89cd30e5be9e150b66c22bc53e886fb550a14e47d191b3c122e6
+SIZE (Sub-Installer-0.0.2.tar.gz) = 4580
diff --git a/devel/p5-Sub-Installer/pkg-descr b/devel/p5-Sub-Installer/pkg-descr
new file mode 100644
index 000000000000..51b0e497ffc5
--- /dev/null
+++ b/devel/p5-Sub-Installer/pkg-descr
@@ -0,0 +1,4 @@
+This module provides two universal methods that any package/class can
+use to install subroutines in its own namespace.
+
+WWW: http://search.cpan.org/dist/Sub-Installer/
diff --git a/devel/p5-Sub-Installer/pkg-plist b/devel/p5-Sub-Installer/pkg-plist
new file mode 100644
index 000000000000..b137bef9cf6d
--- /dev/null
+++ b/devel/p5-Sub-Installer/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Sub/Installer.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Installer/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Installer 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Sub 2>/dev/null || true