aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Sub-Uplevel
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2003-01-28 14:20:01 +0000
committerAnton Berezin <tobez@FreeBSD.org>2003-01-28 14:20:01 +0000
commitf3ecf7501628627e2a9f84ba55be5f1bfd5bb209 (patch)
treec6b87794b9c750b605c6aed6a3902b9a4829cb86 /devel/p5-Sub-Uplevel
parenta0e8d51b2ca28c252cb7155fdd09bdeb7a788f3b (diff)
downloadports-f3ecf7501628627e2a9f84ba55be5f1bfd5bb209.tar.gz
ports-f3ecf7501628627e2a9f84ba55be5f1bfd5bb209.zip
Notes
Diffstat (limited to 'devel/p5-Sub-Uplevel')
-rw-r--r--devel/p5-Sub-Uplevel/Makefile31
-rw-r--r--devel/p5-Sub-Uplevel/distinfo1
-rw-r--r--devel/p5-Sub-Uplevel/pkg-comment1
-rw-r--r--devel/p5-Sub-Uplevel/pkg-descr5
-rw-r--r--devel/p5-Sub-Uplevel/pkg-plist6
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/p5-Sub-Uplevel/Makefile b/devel/p5-Sub-Uplevel/Makefile
new file mode 100644
index 000000000000..7722c1701cc7
--- /dev/null
+++ b/devel/p5-Sub-Uplevel/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Sub-Uplevel
+# Date created: January 27th 2003
+# Whom: Erwin Lansing <erwin@lansing.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sub-Uplevel
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sub
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= erwin@lansing.dk
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Sub::Uplevel.3
+
+.include <bsd.port.pre.mk>
+
+##
+## this port requires PERL 5.6.x or later
+##
+.if ${PERL_LEVEL} < 500600
+BROKEN= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Sub-Uplevel/distinfo b/devel/p5-Sub-Uplevel/distinfo
new file mode 100644
index 000000000000..645068b468ec
--- /dev/null
+++ b/devel/p5-Sub-Uplevel/distinfo
@@ -0,0 +1 @@
+MD5 (Sub-Uplevel-0.06.tar.gz) = 1436ca7aa406c1f8096ca6f56f0c69ed
diff --git a/devel/p5-Sub-Uplevel/pkg-comment b/devel/p5-Sub-Uplevel/pkg-comment
new file mode 100644
index 000000000000..12c5d1135e0b
--- /dev/null
+++ b/devel/p5-Sub-Uplevel/pkg-comment
@@ -0,0 +1 @@
+Sub::Uplevel - apparently run a function in a higher stack frame
diff --git a/devel/p5-Sub-Uplevel/pkg-descr b/devel/p5-Sub-Uplevel/pkg-descr
new file mode 100644
index 000000000000..099dd384f107
--- /dev/null
+++ b/devel/p5-Sub-Uplevel/pkg-descr
@@ -0,0 +1,5 @@
+Like Tcl's uplevel() function, but not quite so
+dangerous. The idea is just to fool caller().
+All the really naughty bits of Tcl's uplevel() are avoided.
+
+WWW: http://search.cpan.org/dist/Sub-Uplevel/
diff --git a/devel/p5-Sub-Uplevel/pkg-plist b/devel/p5-Sub-Uplevel/pkg-plist
new file mode 100644
index 000000000000..0133b0cc9ae1
--- /dev/null
+++ b/devel/p5-Sub-Uplevel/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/mach/auto/Sub/Uplevel/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Sub/Uplevel.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/mach/auto/Sub/Uplevel
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/mach/auto/Sub 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/mach/auto 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Sub 2>/dev/null || true