aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Sys-Info-Base/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-10 00:14:29 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-10 00:14:29 +0000
commitf44c7887d1edae1758a74640a24cbd6ec6810cfc (patch)
tree938011ef2e7305537b9f55b8f766f95c380bc764 /devel/p5-Sys-Info-Base/Makefile
parente8e66240e7d0a3f3afbf368516da945fec676187 (diff)
Notes
Diffstat (limited to 'devel/p5-Sys-Info-Base/Makefile')
-rw-r--r--devel/p5-Sys-Info-Base/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/p5-Sys-Info-Base/Makefile b/devel/p5-Sys-Info-Base/Makefile
new file mode 100644
index 000000000000..73c578894da2
--- /dev/null
+++ b/devel/p5-Sys-Info-Base/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Sys-Info-Base
+# Date created: 2011-10-09
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sys-Info-Base
+PORTVERSION= 0.78.02
+CATEGORIES= devel sysutils perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Base class for Sys::Info
+
+TEST_DEPENDS= p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
+
+PERL_CONFIGURE= yes
+
+MAN3= Sys::Info::Base.3 \
+ Sys::Info::Constants.3 \
+ Sys::Info::Device.3 \
+ Sys::Info::Device::CPU.3 \
+ Sys::Info::Driver.3 \
+ Sys::Info::OS.3
+
+regression-test test: build
+ cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE} test
+
+.include <bsd.port.mk>