aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Sys-Info/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-10 00:20:43 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-10 00:20:43 +0000
commit870cbd67dd1eb9c7787a435048bb116065821907 (patch)
tree487e20b4f1c9ebb2cb0c2b82c778c573265eda22 /devel/p5-Sys-Info/Makefile
parent23de50e8947d5c34ecfb0c83474a27e9fea507b2 (diff)
downloadports-870cbd67dd1eb9c7787a435048bb116065821907.tar.gz
ports-870cbd67dd1eb9c7787a435048bb116065821907.zip
Notes
Diffstat (limited to 'devel/p5-Sys-Info/Makefile')
-rw-r--r--devel/p5-Sys-Info/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/p5-Sys-Info/Makefile b/devel/p5-Sys-Info/Makefile
new file mode 100644
index 000000000000..3db43dd89fdf
--- /dev/null
+++ b/devel/p5-Sys-Info/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Sys-Info
+# Date created: 2011-10-09
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sys-Info
+PORTVERSION= 0.78
+CATEGORIES= devel sysutils perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Fetch information from the host system
+
+BUILD_DEPENDS= p5-Sys-Info-Base>=${PORTVERSION}:${PORTSDIR}/devel/p5-Sys-Info-Base \
+ p5-Sys-Info-Driver-BSD>=${PORTVERSION}:${PORTSDIR}/devel/p5-Sys-Info-Driver-BSD
+RUN_DEPENDS= p5-Sys-Info-Base>=${PORTVERSION}:${PORTSDIR}/devel/p5-Sys-Info-Base \
+ p5-Sys-Info-Driver-BSD>=${PORTVERSION}:${PORTSDIR}/devel/p5-Sys-Info-Driver-BSD
+
+TEST_DEPENDS= p5-Sys-Info-Driver-BSD>=0.20:${PORTSDIR}/devel/p5-Test-Sys-Info \
+ p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
+
+PERL_CONFIGURE= yes
+
+MAN3= Sys::Info.3
+
+.include <bsd.port.mk>