aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Sys-SigAction
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-09-18 18:24:59 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-09-18 18:24:59 +0000
commitc72520c0f06e2fdb6c1dd4f20ae20b12c1ba7662 (patch)
tree37c49be7cbbd0722ed1427b4fba689dfe83cebb4 /devel/p5-Sys-SigAction
parente7cc10c19422cc2c747b834d8439f9a1105fc1d2 (diff)
Notes
Diffstat (limited to 'devel/p5-Sys-SigAction')
-rw-r--r--devel/p5-Sys-SigAction/Makefile25
-rw-r--r--devel/p5-Sys-SigAction/distinfo3
-rw-r--r--devel/p5-Sys-SigAction/pkg-descr6
-rw-r--r--devel/p5-Sys-SigAction/pkg-plist5
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/p5-Sys-SigAction/Makefile b/devel/p5-Sys-SigAction/Makefile
new file mode 100644
index 000000000000..b8e74bbead65
--- /dev/null
+++ b/devel/p5-Sys-SigAction/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Sys-SigAction
+# Date created: 18 Sep 2006
+# Whom: svysh
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sys-SigAction
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sys
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svysh@cryptocom.ru
+COMMENT= Perl extension for Consistent Signal Handling
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Sys::SigAction.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Sys-SigAction/distinfo b/devel/p5-Sys-SigAction/distinfo
new file mode 100644
index 000000000000..b1029184bbb7
--- /dev/null
+++ b/devel/p5-Sys-SigAction/distinfo
@@ -0,0 +1,3 @@
+MD5 (Sys-SigAction-0.06.tar.gz) = 388847720377789d68417ec5f28ce677
+SHA256 (Sys-SigAction-0.06.tar.gz) = 8df87180a1fe321b1d4df26c22e68a7dd3af4387b615a5bb8b05255237731815
+SIZE (Sys-SigAction-0.06.tar.gz) = 13127
diff --git a/devel/p5-Sys-SigAction/pkg-descr b/devel/p5-Sys-SigAction/pkg-descr
new file mode 100644
index 000000000000..2caedae29a4a
--- /dev/null
+++ b/devel/p5-Sys-SigAction/pkg-descr
@@ -0,0 +1,6 @@
+Sys::SigAction - Perl extension for Consistent Signal Handling.
+With the use of this module, the signal handling behavior
+can be coded in a way that does not change from one perl version
+to the next, and thus using POSIX::sigaction() becomes a little easier.
+
+WWW: http://search.cpan.org/dist/Sys-SigAction/
diff --git a/devel/p5-Sys-SigAction/pkg-plist b/devel/p5-Sys-SigAction/pkg-plist
new file mode 100644
index 000000000000..c7b5dcd2bb4a
--- /dev/null
+++ b/devel/p5-Sys-SigAction/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Sys/SigAction.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/SigAction/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys/SigAction
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sys
+@dirrmtry %%SITE_PERL%%/Sys