aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Task-Weaken
diff options
context:
space:
mode:
authorLars Balker Rasmussen <lbr@FreeBSD.org>2007-04-06 08:21:03 +0000
committerLars Balker Rasmussen <lbr@FreeBSD.org>2007-04-06 08:21:03 +0000
commitb140e96e01305f42575294c1785b80b05aac3fba (patch)
tree6176462756c8a8068ae07a38b55d9d3464bff34d /devel/p5-Task-Weaken
parent922ad0cb2d84aeed07e660af0f918d0a961035a9 (diff)
Notes
Diffstat (limited to 'devel/p5-Task-Weaken')
-rw-r--r--devel/p5-Task-Weaken/Makefile26
-rw-r--r--devel/p5-Task-Weaken/distinfo3
-rw-r--r--devel/p5-Task-Weaken/pkg-descr23
-rw-r--r--devel/p5-Task-Weaken/pkg-plist6
4 files changed, 58 insertions, 0 deletions
diff --git a/devel/p5-Task-Weaken/Makefile b/devel/p5-Task-Weaken/Makefile
new file mode 100644
index 000000000000..e56e461f4d38
--- /dev/null
+++ b/devel/p5-Task-Weaken/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: p5-Task-Weaken
+# Date created: Apr 5, 2007
+# Whom: lbr@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Task-Weaken
+PORTVERSION= 0.99
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Task
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lbr@FreeBSD.org
+COMMENT= Ensure that a platform has weaken support
+
+PERL_CONFIGURE= yes
+
+MAN3= Task::Weaken.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500805
+IGNORE= requires at least Perl 5.8.5. (Re-)install lang/perl5.8 and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Task-Weaken/distinfo b/devel/p5-Task-Weaken/distinfo
new file mode 100644
index 000000000000..81326575bed8
--- /dev/null
+++ b/devel/p5-Task-Weaken/distinfo
@@ -0,0 +1,3 @@
+MD5 (Task-Weaken-0.99.tar.gz) = 92de456b6d1be928428babb7ebcdc6c1
+SHA256 (Task-Weaken-0.99.tar.gz) = bc1bd0fa3c77eb090f4a7dbeca349a503d686471fbd1fc5ffa8c07f2ab785e0e
+SIZE (Task-Weaken-0.99.tar.gz) = 19917
diff --git a/devel/p5-Task-Weaken/pkg-descr b/devel/p5-Task-Weaken/pkg-descr
new file mode 100644
index 000000000000..f579c31fc4c8
--- /dev/null
+++ b/devel/p5-Task-Weaken/pkg-descr
@@ -0,0 +1,23 @@
+One recurring problem in modules that use Scalar::Util's weaken function is
+that it is not present in the pure-perl variant.
+
+While this isn't necesarily always a problem in a straight CPAN-based Perl
+environment, some operating system distributions only include the pure-Perl
+versions, don't include the XS version, and so weaken is then "missing" from
+the platform, despite passing a dependency on Scalar::Util successfully.
+
+Most notably this is RedHat Linux at time of writing, but other come and go
+and do the same thing, hence "recurring problem".
+
+The normal solution is to manually write tests in each distribution to ensure
+that weaken is available.
+
+This restores the functionality testing to a dependency you do once in your
+Makefile.PL, rather than something you have to write extra tests for each
+time you write a module.
+
+It should also help make the package auto-generators for the various
+operating systems play more nicely, because it introduces a dependency that
+they have to have a proper weaken in order to work.
+
+WWW: http://search.cpan.org/dist/Task-Weaken/
diff --git a/devel/p5-Task-Weaken/pkg-plist b/devel/p5-Task-Weaken/pkg-plist
new file mode 100644
index 000000000000..5f91b681af0c
--- /dev/null
+++ b/devel/p5-Task-Weaken/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Task/Weaken.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Task/Weaken/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Task/Weaken
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Task
+@dirrmtry %%SITE_PERL%%/Task/Weaken
+@dirrmtry %%SITE_PERL%%/Task