aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Term-Visual
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-03-22 15:20:33 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-03-22 15:20:33 +0000
commit9bdef468cc0de954689f7120f27f2a20b3560362 (patch)
tree22f631be3b5987bb02870e9218c332d4596368d5 /devel/p5-Term-Visual
parent8b4204627112863724a1d3151b941bc0b92433c0 (diff)
downloadports-9bdef468cc0de954689f7120f27f2a20b3560362.tar.gz
ports-9bdef468cc0de954689f7120f27f2a20b3560362.zip
Notes
Diffstat (limited to 'devel/p5-Term-Visual')
-rw-r--r--devel/p5-Term-Visual/Makefile26
-rw-r--r--devel/p5-Term-Visual/distinfo3
-rw-r--r--devel/p5-Term-Visual/pkg-descr9
-rw-r--r--devel/p5-Term-Visual/pkg-plist7
4 files changed, 45 insertions, 0 deletions
diff --git a/devel/p5-Term-Visual/Makefile b/devel/p5-Term-Visual/Makefile
new file mode 100644
index 000000000000..5eb0f60a0754
--- /dev/null
+++ b/devel/p5-Term-Visual/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Term-Visual
+# Date created: 2007/03/21
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Term-Visual
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Term
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Split-terminal user interface
+
+BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-Curses>=0:${PORTSDIR}/devel/p5-Curses
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Term::Visual.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Term-Visual/distinfo b/devel/p5-Term-Visual/distinfo
new file mode 100644
index 000000000000..e1a769e5feba
--- /dev/null
+++ b/devel/p5-Term-Visual/distinfo
@@ -0,0 +1,3 @@
+MD5 (Term-Visual-0.06.tar.gz) = 1e51b5236a0756eea73a2709394596a9
+SHA256 (Term-Visual-0.06.tar.gz) = 0f11b87d48421e99ebc47a295679cf1fdda8ff05290acb9320fbd8bcecd1bd3b
+SIZE (Term-Visual-0.06.tar.gz) = 34617
diff --git a/devel/p5-Term-Visual/pkg-descr b/devel/p5-Term-Visual/pkg-descr
new file mode 100644
index 000000000000..b1ae06a885c3
--- /dev/null
+++ b/devel/p5-Term-Visual/pkg-descr
@@ -0,0 +1,9 @@
+Term::Visual is a "visual" terminal interface for curses applications. It
+provides the split-screen interface you may have seen in console based IRC
+and MUD clients.
+
+Term::Visual uses the POE networking and multitasking framework to support
+concurrent input from network sockets and the console, multiple timers, and
+more.
+
+WWW: http://search.cpan.org/dist/Term-Visual/
diff --git a/devel/p5-Term-Visual/pkg-plist b/devel/p5-Term-Visual/pkg-plist
new file mode 100644
index 000000000000..ac98563ffa7f
--- /dev/null
+++ b/devel/p5-Term-Visual/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/Visual/.packlist
+%%SITE_PERL%%/Term/Visual.pm
+%%SITE_PERL%%/Term/Visual/StatusBar.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/Visual
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term
+@dirrmtry %%SITE_PERL%%/Term/Visual
+@dirrmtry %%SITE_PERL%%/Term