aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Base
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-12-27 11:27:47 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-12-27 11:27:47 +0000
commita1d851e348fa5b19685cb6d739296caa25a24656 (patch)
treef657a8923b9d9313ece8548e90c291096ad58d9e /devel/p5-Test-Base
parentce08089229244ab6984b168f7825751a67b35744 (diff)
downloadports-a1d851e348fa5b19685cb6d739296caa25a24656.tar.gz
ports-a1d851e348fa5b19685cb6d739296caa25a24656.zip
Notes
Diffstat (limited to 'devel/p5-Test-Base')
-rw-r--r--devel/p5-Test-Base/Makefile35
-rw-r--r--devel/p5-Test-Base/distinfo3
-rw-r--r--devel/p5-Test-Base/pkg-descr11
-rw-r--r--devel/p5-Test-Base/pkg-plist7
4 files changed, 56 insertions, 0 deletions
diff --git a/devel/p5-Test-Base/Makefile b/devel/p5-Test-Base/Makefile
new file mode 100644
index 000000000000..3816031114ba
--- /dev/null
+++ b/devel/p5-Test-Base/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: devel/p5-Test-Base
+# Date created: 27 Dec 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Base
+PORTVERSION= 0.44
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Test::Base - A Data Driven Testing Framework
+
+BUILD_DEPENDS= \
+ p5-Spiffy>=0.24:${PORTSDIR}/devel/p5-Spiffy \
+ p5-MIME-Base64>0:${PORTSDIR}/converters/p5-MIME-Base64 \
+ p5-Test-Simple>=0.54:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Base.3 \
+ Test::Base::Filter.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Base/distinfo b/devel/p5-Test-Base/distinfo
new file mode 100644
index 000000000000..56d544a4b9f1
--- /dev/null
+++ b/devel/p5-Test-Base/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Base-0.44.tar.gz) = 36a3c04b89daafbb498d2075b287aee7
+SHA256 (Test-Base-0.44.tar.gz) = ab72093dc95caa7cfcb2b5e686f10d5379fcba3aa449267fc9a52cca2253188d
+SIZE (Test-Base-0.44.tar.gz) = 40189
diff --git a/devel/p5-Test-Base/pkg-descr b/devel/p5-Test-Base/pkg-descr
new file mode 100644
index 000000000000..f18485d29b3d
--- /dev/null
+++ b/devel/p5-Test-Base/pkg-descr
@@ -0,0 +1,11 @@
+Testing is usually the ugly part of Perl module authoring. Perl gives
+you a standard way to run tests with Test::Harness, and basic testing
+primitives with Test::More. After that you are pretty much on your own
+to develop a testing framework and philosophy. Test::More encourages you
+to make your own framework by subclassing Test::Builder, but that is not
+trivial.
+
+Test::Base gives you a way to write your own test framework base class
+that *is* trivial.
+
+WWW: http://search.cpan.org/dist/Test-Base/
diff --git a/devel/p5-Test-Base/pkg-plist b/devel/p5-Test-Base/pkg-plist
new file mode 100644
index 000000000000..b15ae72ddb26
--- /dev/null
+++ b/devel/p5-Test-Base/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Base/.packlist
+%%SITE_PERL%%/Test/Base.pm
+%%SITE_PERL%%/Test/Base/Filter.pm
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Base 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test/Base 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test 2>/dev/null || true