aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-BinaryData
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-12-15 07:13:01 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-12-15 07:13:01 +0000
commit45bb1fffefcf720026076f37c252c78a5828dae7 (patch)
treead5ceabae235a3a586429400de05bf1a4ec0e962 /devel/p5-Test-BinaryData
parente83d26aeafab1bb3054c7261b1a2a386b91b4ef0 (diff)
downloadports-45bb1fffefcf720026076f37c252c78a5828dae7.tar.gz
ports-45bb1fffefcf720026076f37c252c78a5828dae7.zip
Notes
Diffstat (limited to 'devel/p5-Test-BinaryData')
-rw-r--r--devel/p5-Test-BinaryData/Makefile29
-rw-r--r--devel/p5-Test-BinaryData/distinfo2
-rw-r--r--devel/p5-Test-BinaryData/pkg-descr7
-rw-r--r--devel/p5-Test-BinaryData/pkg-plist5
4 files changed, 43 insertions, 0 deletions
diff --git a/devel/p5-Test-BinaryData/Makefile b/devel/p5-Test-BinaryData/Makefile
new file mode 100644
index 000000000000..0bf903909b4c
--- /dev/null
+++ b/devel/p5-Test-BinaryData/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Test-BinaryData
+# Date created: 2011-12-15
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-BinaryData
+PORTVERSION= 0.013
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Compare two things, give hex dumps if they differ
+
+TEST_DEPENDS= p5-Test-Tester>=0.10.7:${PORTSDIR}/devel/p5-Test-Tester
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::BinaryData.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501400
+TEST_DEPENDS+= p5-Test-Simple>=0.96:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-BinaryData/distinfo b/devel/p5-Test-BinaryData/distinfo
new file mode 100644
index 000000000000..6b680cb4747a
--- /dev/null
+++ b/devel/p5-Test-BinaryData/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Test-BinaryData-0.013.tar.gz) = 6aa709b0ab6951de90985478c21a196d8bf502f5dabc056eb1d47d64ccf80611
+SIZE (Test-BinaryData-0.013.tar.gz) = 14859
diff --git a/devel/p5-Test-BinaryData/pkg-descr b/devel/p5-Test-BinaryData/pkg-descr
new file mode 100644
index 000000000000..16f6a2483e19
--- /dev/null
+++ b/devel/p5-Test-BinaryData/pkg-descr
@@ -0,0 +1,7 @@
+Sometimes using Test::More's is test isn't good enough. Its diagnostics may make
+it easy to miss differences between strings. By using is_binary instead of is,
+the "!" tells us that the lines differ, and we can quickly scan the bytes that
+make up the line to see which differ. When comparing very long strings, we can
+stop after we've seen a few differences.
+
+WWW: http://search.cpan.org/dist/Test-BinaryData/
diff --git a/devel/p5-Test-BinaryData/pkg-plist b/devel/p5-Test-BinaryData/pkg-plist
new file mode 100644
index 000000000000..01e2189aadd1
--- /dev/null
+++ b/devel/p5-Test-BinaryData/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Test/BinaryData.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/BinaryData/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/BinaryData
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test