aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Block
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2008-04-16 13:58:41 +0000
committerLars Thegler <lth@FreeBSD.org>2008-04-16 13:58:41 +0000
commit26e5785fed9d7fcf78060e9aa7fe777d0cca1e18 (patch)
tree07bae8d977505d737a1f4b12c7f5c5d883b5a809 /devel/p5-Test-Block
parent1db359e8ac0eab2b14b4d6a48cc08f2ed52086f5 (diff)
downloadports-26e5785fed9d7fcf78060e9aa7fe777d0cca1e18.tar.gz
ports-26e5785fed9d7fcf78060e9aa7fe777d0cca1e18.zip
Notes
Diffstat (limited to 'devel/p5-Test-Block')
-rw-r--r--devel/p5-Test-Block/Makefile26
-rw-r--r--devel/p5-Test-Block/distinfo3
-rw-r--r--devel/p5-Test-Block/pkg-descr5
-rw-r--r--devel/p5-Test-Block/pkg-plist5
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/p5-Test-Block/Makefile b/devel/p5-Test-Block/Makefile
new file mode 100644
index 000000000000..082992583e13
--- /dev/null
+++ b/devel/p5-Test-Block/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: devel/p5-Test-Block
+# Date created: 16 April 2008
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Block
+PORTVERSION= 0.11
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Specify fine granularity test plans
+
+BUILD_DEPENDS= p5-Test-Exception>=0.15:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-Simple>=0.47:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= 5.6.1+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Block.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Block/distinfo b/devel/p5-Test-Block/distinfo
new file mode 100644
index 000000000000..11cae420b880
--- /dev/null
+++ b/devel/p5-Test-Block/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Block-0.11.tar.gz) = 386a722947f2c77f6157d1dea0338e35
+SHA256 (Test-Block-0.11.tar.gz) = 1d836fdeb1e4082ccec6b46b9231b3f16004611a2b3e63ec51dc02016e4587b4
+SIZE (Test-Block-0.11.tar.gz) = 7568
diff --git a/devel/p5-Test-Block/pkg-descr b/devel/p5-Test-Block/pkg-descr
new file mode 100644
index 000000000000..28a068525e70
--- /dev/null
+++ b/devel/p5-Test-Block/pkg-descr
@@ -0,0 +1,5 @@
+This module allows you to specify the number of expected tests at
+a finer level of granularity than an entire test script. It is built
+with Test::Builder and plays happily with Test::More and friends.
+
+WWW: http://search.cpan.org/dist/Test-Block/
diff --git a/devel/p5-Test-Block/pkg-plist b/devel/p5-Test-Block/pkg-plist
new file mode 100644
index 000000000000..d306a488aa3e
--- /dev/null
+++ b/devel/p5-Test-Block/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Test/Block.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Block/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Block
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test