aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-CheckDeps/Makefile
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2012-07-07 07:05:03 +0000
committerFrederic Culot <culot@FreeBSD.org>2012-07-07 07:05:03 +0000
commitb3411921b6009ae2bcd1bb61f484cee23bbe2649 (patch)
tree49a413556882eb84b761dcf940871b6d5b7e420d /devel/p5-Test-CheckDeps/Makefile
parent55449884dd2cdf5f815746f67ac755bebf3bc93f (diff)
Notes
Diffstat (limited to 'devel/p5-Test-CheckDeps/Makefile')
-rw-r--r--devel/p5-Test-CheckDeps/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/devel/p5-Test-CheckDeps/Makefile b/devel/p5-Test-CheckDeps/Makefile
new file mode 100644
index 000000000000..ae699b3ac86a
--- /dev/null
+++ b/devel/p5-Test-CheckDeps/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: devel/p5-Test-CheckDeps
+# Date created: 2012-07-06
+# Whom: Frederic Culot <culot@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-CheckDeps
+PORTVERSION= 0.002
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= culot@FreeBSD.org
+COMMENT= Check for presence of dependencies
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-CPAN-Meta-Check>0:${PORTSDIR}/devel/p5-CPAN-Meta-Check
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::CheckDeps.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.if ${PERL_LEVEL} < 501400
+BUILD_DEPENDS+= p5-CPAN-Meta>0:${PORTSDIR}/devel/p5-CPAN-Meta \
+ p5-Module-Metadata>0:${PORTSDIR}/devel/p5-Module-Metadata
+RUN_DEPENDS+= p5-CPAN-Meta>0:${PORTSDIR}/devel/p5-CPAN-Meta \
+ p5-Module-Metadata>0:${PORTSDIR}/devel/p5-Module-Metadata
+.endif
+
+.include <bsd.port.post.mk>