aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-CheckDeps
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2012-07-07 07:05:03 +0000
committerFrederic Culot <culot@FreeBSD.org>2012-07-07 07:05:03 +0000
commitb3411921b6009ae2bcd1bb61f484cee23bbe2649 (patch)
tree49a413556882eb84b761dcf940871b6d5b7e420d /devel/p5-Test-CheckDeps
parent55449884dd2cdf5f815746f67ac755bebf3bc93f (diff)
downloadports-b3411921b6009ae2bcd1bb61f484cee23bbe2649.tar.gz
ports-b3411921b6009ae2bcd1bb61f484cee23bbe2649.zip
Notes
Diffstat (limited to 'devel/p5-Test-CheckDeps')
-rw-r--r--devel/p5-Test-CheckDeps/Makefile40
-rw-r--r--devel/p5-Test-CheckDeps/distinfo2
-rw-r--r--devel/p5-Test-CheckDeps/pkg-descr4
-rw-r--r--devel/p5-Test-CheckDeps/pkg-plist5
4 files changed, 51 insertions, 0 deletions
diff --git a/devel/p5-Test-CheckDeps/Makefile b/devel/p5-Test-CheckDeps/Makefile
new file mode 100644
index 000000000000..ae699b3ac86a
--- /dev/null
+++ b/devel/p5-Test-CheckDeps/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: devel/p5-Test-CheckDeps
+# Date created: 2012-07-06
+# Whom: Frederic Culot <culot@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-CheckDeps
+PORTVERSION= 0.002
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= culot@FreeBSD.org
+COMMENT= Check for presence of dependencies
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-CPAN-Meta-Check>0:${PORTSDIR}/devel/p5-CPAN-Meta-Check
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::CheckDeps.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.if ${PERL_LEVEL} < 501400
+BUILD_DEPENDS+= p5-CPAN-Meta>0:${PORTSDIR}/devel/p5-CPAN-Meta \
+ p5-Module-Metadata>0:${PORTSDIR}/devel/p5-Module-Metadata
+RUN_DEPENDS+= p5-CPAN-Meta>0:${PORTSDIR}/devel/p5-CPAN-Meta \
+ p5-Module-Metadata>0:${PORTSDIR}/devel/p5-Module-Metadata
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-CheckDeps/distinfo b/devel/p5-Test-CheckDeps/distinfo
new file mode 100644
index 000000000000..c2a8a7872756
--- /dev/null
+++ b/devel/p5-Test-CheckDeps/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Test-CheckDeps-0.002.tar.gz) = 2696298bbf0720af39ea3b82db583ec280db0dcb2c9b85574a85aaf8744fb53a
+SIZE (Test-CheckDeps-0.002.tar.gz) = 10964
diff --git a/devel/p5-Test-CheckDeps/pkg-descr b/devel/p5-Test-CheckDeps/pkg-descr
new file mode 100644
index 000000000000..527e212d3d68
--- /dev/null
+++ b/devel/p5-Test-CheckDeps/pkg-descr
@@ -0,0 +1,4 @@
+Test::CheckDeps adds a test that assures all dependencies have been
+installed properly. If requested, it can bail out all testing on error.
+
+WWW: http://search.cpan.org/dist/Test-CheckDeps/
diff --git a/devel/p5-Test-CheckDeps/pkg-plist b/devel/p5-Test-CheckDeps/pkg-plist
new file mode 100644
index 000000000000..a804cfde8a48
--- /dev/null
+++ b/devel/p5-Test-CheckDeps/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Test/CheckDeps.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/CheckDeps/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/CheckDeps
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test