aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Class/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-02-05 09:45:20 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-02-05 09:45:20 +0000
commit2788b970ec932cb316a419395e698515a5e8efd2 (patch)
tree9b5cffc10511faeda911fc732abf979228c9e4d0 /devel/p5-Test-Class/Makefile
parentc32a782feab8fd89090dae5ae7d675d7e07c1b38 (diff)
New port: Test::Class - Easily create test classes in an xUnit style
Test::Class provides a simple way of creating classes and objects to test your code in an xUnit style. Built using Test::Builder it is designing to work with other Test::Builder based modules (Test::More, Test::Differences, Test::Exception, etc.) Note: This module will make more sense if you are already familiar with the "standard" mechanisms for testing perl code. Those unfamiliar with Test::Harness, Test::Simple, Test::More and friends should go take a look at them now. PR: ports/47589 Submitted by: Erwin Lansing <erwin@lansing.dk>
Notes
Notes: svn path=/head/; revision=74817
Diffstat (limited to 'devel/p5-Test-Class/Makefile')
-rw-r--r--devel/p5-Test-Class/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/devel/p5-Test-Class/Makefile b/devel/p5-Test-Class/Makefile
new file mode 100644
index 000000000000..d09268656d69
--- /dev/null
+++ b/devel/p5-Test-Class/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-Test-Class
+# Date created: January 27th 2003
+# Whom: Erwin Lansing <erwin@lansing.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Class
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= erwin@lansing.dk
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Attribute/Handlers.pm:${PORTSDIR}/devel/p5-Attribute-Handlers \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Differences.pm:${PORTSDIR}/devel/p5-Test-Differences
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Test::Class.3
+
+.include <bsd.port.pre.mk>
+
+##
+## this port requires PERL 5.6.x or later
+##
+.if ${PERL_LEVEL} < 500600
+BROKEN= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>