aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Class
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-10-31 01:53:11 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-10-31 01:53:11 +0000
commitddb3d8a6c6ca9a7bbfc3f2c741337fd0fca3aad9 (patch)
treed05c6ad4ea055f9ce98ec8c4a5ccf233ec376dfd /devel/p5-Test-Class
parent16d9570b4c909ad36c093a5328a464807d6e5143 (diff)
downloadports-ddb3d8a6c6ca9a7bbfc3f2c741337fd0fca3aad9.tar.gz
ports-ddb3d8a6c6ca9a7bbfc3f2c741337fd0fca3aad9.zip
Notes
Diffstat (limited to 'devel/p5-Test-Class')
-rw-r--r--devel/p5-Test-Class/Makefile36
-rw-r--r--devel/p5-Test-Class/distinfo6
-rw-r--r--devel/p5-Test-Class/pkg-plist7
3 files changed, 21 insertions, 28 deletions
diff --git a/devel/p5-Test-Class/Makefile b/devel/p5-Test-Class/Makefile
index 70124d539803..17ec19047d1e 100644
--- a/devel/p5-Test-Class/Makefile
+++ b/devel/p5-Test-Class/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Test-Class
-PORTVERSION= 0.18
+PORTVERSION= 0.20
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Test
@@ -15,34 +15,28 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Test::Class - Easily create test classes in an xUnit style
-BUILD_DEPENDS= ${SITE_PERL}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
- ${SITE_PERL}/Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump \
- ${SITE_PERL}/Test/Differences.pm:${PORTSDIR}/devel/p5-Test-Differences
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Devel-Symdump>=2.03:${PORTSDIR}/devel/p5-Devel-Symdump
-PERL_CONFIGURE= yes
+PERL_MODBUILD= yes
MAN3= Test::Class.3 \
- Test::Class::MethodInfo.3 \
- Test::Class::Load.3
+ Test::Class::Load.3 \
+ Test::Class::MethodInfo.3
.include <bsd.port.pre.mk>
-##
-## this port requires PERL 5.6.x or later
-##
-.if ${PERL_LEVEL} < 500601
-IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
+.if ${PERL_LEVEL} < 500702
+RUN_DEPENDS+= p5-Attribute-Handlers>=0.77:${PORTSDIR}/devel/p5-Attribute-Handlers
+.if ${PERL_LEVEL} < 500701
+RUN_DEPENDS+= p5-Class-ISA>=0.32:${PORTSDIR}/devel/p5-Class-ISA
+.if ${PERL_LEVEL} < 500700
+RUN_DEPENDS+= p5-Storable>=2.04:${PORTSDIR}/devel/p5-Storable
+.endif
+.endif
.endif
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${SITE_PERL}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
- ${SITE_PERL}/Attribute/Handlers.pm:${PORTSDIR}/devel/p5-Attribute-Handlers
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${SITE_PERL}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
- ${SITE_PERL}/Attribute/Handlers.pm:${PORTSDIR}/devel/p5-Attribute-Handlers
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.1 or later. Install lang/perl5.8 then try again
.endif
.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Class/distinfo b/devel/p5-Test-Class/distinfo
index a6682e5ec9a4..addde57b5d19 100644
--- a/devel/p5-Test-Class/distinfo
+++ b/devel/p5-Test-Class/distinfo
@@ -1,3 +1,3 @@
-MD5 (Test-Class-0.18.tar.gz) = a6dfa503937de152396b3c227f409caa
-SHA256 (Test-Class-0.18.tar.gz) = 5d7b0c3f2f89359c4ceb917519b59a8980ea6496651dec91710b0ab9f916c4b9
-SIZE (Test-Class-0.18.tar.gz) = 44644
+MD5 (Test-Class-0.20.tar.gz) = 66a96dd9acfc2256b54012a3487ccf87
+SHA256 (Test-Class-0.20.tar.gz) = 5132bcd47533a26e01623431a7b0b483dbbf12f4d29a66980a5e42f110ab2441
+SIZE (Test-Class-0.20.tar.gz) = 45869
diff --git a/devel/p5-Test-Class/pkg-plist b/devel/p5-Test-Class/pkg-plist
index e1c82b98fec8..5351d6de652d 100644
--- a/devel/p5-Test-Class/pkg-plist
+++ b/devel/p5-Test-Class/pkg-plist
@@ -1,7 +1,6 @@
-%%SITE_PERL%%/mach/auto/Test/Class/.packlist
+@comment $FreeBSD$
%%SITE_PERL%%/Test/Class.pm
-%%SITE_PERL%%/Test/Class/MethodInfo.pm
%%SITE_PERL%%/Test/Class/Load.pm
-@dirrm %%SITE_PERL%%/Test/Class
-@dirrm %%SITE_PERL%%/mach/auto/Test/Class
+%%SITE_PERL%%/Test/Class/MethodInfo.pm
+@dirrmtry %%SITE_PERL%%/Test/Class
@dirrmtry %%SITE_PERL%%/Test