aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Class
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-10-24 12:05:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-10-24 12:05:09 +0000
commitc634b4bb839753aec2ae1040e2c80a5282402cb8 (patch)
treed8b3fc97550f860aeb41c57751d2550e9ad6273e /devel/p5-Test-Class
parent386f40a6b587557ff9ef6bed9fccca2490a5d78d (diff)
downloadports-c634b4bb839753aec2ae1040e2c80a5282402cb8.tar.gz
ports-c634b4bb839753aec2ae1040e2c80a5282402cb8.zip
Notes
Diffstat (limited to 'devel/p5-Test-Class')
-rw-r--r--devel/p5-Test-Class/Makefile22
-rw-r--r--devel/p5-Test-Class/pkg-plist8
2 files changed, 15 insertions, 15 deletions
diff --git a/devel/p5-Test-Class/Makefile b/devel/p5-Test-Class/Makefile
index fc2bf5fb1274..c42932ff0db6 100644
--- a/devel/p5-Test-Class/Makefile
+++ b/devel/p5-Test-Class/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@FreeBSD.org
COMMENT= Test::Class - Easily create test classes in an xUnit style
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Differences.pm:${PORTSDIR}/devel/p5-Test-Differences
+BUILD_DEPENDS= ${SITE_PERL}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester \
+ ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
+ ${SITE_PERL}/Test/Differences.pm:${PORTSDIR}/devel/p5-Test-Differences
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -34,14 +34,14 @@ IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
.endif
.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Attribute/Handlers.pm:${PORTSDIR}/devel/p5-Attribute-Handlers
-RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Attribute/Handlers.pm:${PORTSDIR}/devel/p5-Attribute-Handlers
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${SITE_PERL}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
+ ${SITE_PERL}/Attribute/Handlers.pm:${PORTSDIR}/devel/p5-Attribute-Handlers
+RUN_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${SITE_PERL}/Class/ISA.pm:${PORTSDIR}/devel/p5-Class-ISA \
+ ${SITE_PERL}/Attribute/Handlers.pm:${PORTSDIR}/devel/p5-Attribute-Handlers
.endif
.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Class/pkg-plist b/devel/p5-Test-Class/pkg-plist
index 4e8bc3955165..b3a3c65e7bc4 100644
--- a/devel/p5-Test-Class/pkg-plist
+++ b/devel/p5-Test-Class/pkg-plist
@@ -1,4 +1,4 @@
-lib/perl5/site_perl/%%PERL_VER%%/mach/auto/Test/Class/.packlist
-lib/perl5/site_perl/%%PERL_VER%%/Test/Class.pm
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/mach/auto/Test/Class
-@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Test 2>/dev/null || true
+%%SITE_PERL%%/mach/auto/Test/Class/.packlist
+%%SITE_PERL%%/Test/Class.pm
+@dirrm %%SITE_PERL%%/mach/auto/Test/Class
+@unexec rmdir %D/%%SITE_PERL%%/Test 2>/dev/null || true