aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Deep/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2004-10-30 08:42:30 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2004-10-30 08:42:30 +0000
commitafc2d33becc76aac62350f46d0cb421438e820f8 (patch)
tree98d09611b9a82879bf286ebe244c8b2054ea7ece /devel/p5-Test-Deep/Makefile
parent41cb81d2e54206daa6406ccb86b390d09e9f7786 (diff)
downloadports-afc2d33becc76aac62350f46d0cb421438e820f8.tar.gz
ports-afc2d33becc76aac62350f46d0cb421438e820f8.zip
Notes
Diffstat (limited to 'devel/p5-Test-Deep/Makefile')
-rw-r--r--devel/p5-Test-Deep/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/p5-Test-Deep/Makefile b/devel/p5-Test-Deep/Makefile
new file mode 100644
index 000000000000..b54164625ded
--- /dev/null
+++ b/devel/p5-Test-Deep/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Test-Deep
+# Date created: May 12th 2004
+# Whom: Alex Kapranoff <alex@kapranoff.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Deep
+PORTVERSION= 0.087
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Test data structures for differences deeply
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/NoWarnings.pm:${PORTSDIR}/devel/p5-Test-NoWarnings \
+ ${SITE_PERL}/Test/Tester.pm:${PORTSDIR}/devel/p5-Test-Tester \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+INSTALL_TARGET= pure_install
+
+MAN3= Test::Deep.3
+
+post-patch:
+ @${PERL} -i -pe 'm/INSTALLDIRS\s+=>/ and $$_ = ""' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>