aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-FailWarnings/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2013-04-25 08:49:43 +0000
committerAnton Berezin <tobez@FreeBSD.org>2013-04-25 08:49:43 +0000
commite577fa4c37fec255cda7790793d8466d2893ba47 (patch)
treea772115c13f118970a4380c024a1aea491e70095 /devel/p5-Test-FailWarnings/Makefile
parentc45324e9f6d08e75105172275d5af71c49ac1de1 (diff)
downloadports-e577fa4c37fec255cda7790793d8466d2893ba47.tar.gz
ports-e577fa4c37fec255cda7790793d8466d2893ba47.zip
Notes
Diffstat (limited to 'devel/p5-Test-FailWarnings/Makefile')
-rw-r--r--devel/p5-Test-FailWarnings/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/devel/p5-Test-FailWarnings/Makefile b/devel/p5-Test-FailWarnings/Makefile
new file mode 100644
index 000000000000..6161e4815af9
--- /dev/null
+++ b/devel/p5-Test-FailWarnings/Makefile
@@ -0,0 +1,21 @@
+# Created by: Anton Berezin <tobez@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Test-FailWarnings
+PORTVERSION= 0.003
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Add test failures if warnings are caught
+
+BUILD_DEPENDS= p5-Capture-Tiny>=0.21:${PORTSDIR}/devel/p5-Capture-Tiny
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::FailWarnings.3
+
+.include <bsd.port.mk>