aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Lazy
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-02-24 03:47:27 +0000
committerSteve Wills <swills@FreeBSD.org>2012-02-24 03:47:27 +0000
commit2e7df9db6767949f6cb7ba7f1aee55090d30cc83 (patch)
tree15b416d2a005ccd94cb86d7e1bca484d39e4d012 /devel/p5-Test-Lazy
parente60734ff9c8115777c51eee20e1c752c93a492f3 (diff)
Notes
Diffstat (limited to 'devel/p5-Test-Lazy')
-rw-r--r--devel/p5-Test-Lazy/Makefile25
-rw-r--r--devel/p5-Test-Lazy/distinfo2
-rw-r--r--devel/p5-Test-Lazy/pkg-descr3
-rw-r--r--devel/p5-Test-Lazy/pkg-plist6
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/p5-Test-Lazy/Makefile b/devel/p5-Test-Lazy/Makefile
new file mode 100644
index 000000000000..ad4f8fb5bb5c
--- /dev/null
+++ b/devel/p5-Test-Lazy/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Test-Lazy
+# Date created: 2012-02-23
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Lazy
+PORTVERSION= 0.061
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A quick and easy way to compose and run tests with useful output
+
+BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Test-Deep>0:${PORTSDIR}/devel/p5-Test-Deep
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Lazy.3 Test::Lazy::Template.3 Test::Lazy::Tester.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Lazy/distinfo b/devel/p5-Test-Lazy/distinfo
new file mode 100644
index 000000000000..0d984fa1e14b
--- /dev/null
+++ b/devel/p5-Test-Lazy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Test-Lazy-0.061.tar.gz) = ab018ca15147cef4f15f8e7f6bec62ffd312505b64b309d8b798ad4478ecaf77
+SIZE (Test-Lazy-0.061.tar.gz) = 8444
diff --git a/devel/p5-Test-Lazy/pkg-descr b/devel/p5-Test-Lazy/pkg-descr
new file mode 100644
index 000000000000..fc603e5d1faa
--- /dev/null
+++ b/devel/p5-Test-Lazy/pkg-descr
@@ -0,0 +1,3 @@
+A quick and easy way to compose and run tests with useful output.
+
+WWW: http://search.cpan.org/dist/Test-Lazy/
diff --git a/devel/p5-Test-Lazy/pkg-plist b/devel/p5-Test-Lazy/pkg-plist
new file mode 100644
index 000000000000..d55b786e0d54
--- /dev/null
+++ b/devel/p5-Test-Lazy/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Test/Lazy/Tester.pm
+%%SITE_PERL%%/Test/Lazy/Template.pm
+%%SITE_PERL%%/Test/Lazy.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Lazy/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Lazy
+@dirrmtry %%SITE_PERL%%/Test/Lazy