aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-LoadAllModules/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2009-02-27 07:20:38 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2009-02-27 07:20:38 +0000
commit9bb0e048debf40a39170c467bd0786258876f51e (patch)
tree8e911cb2e2b0a28e2f7a8cf78bb3fee1fd5d7db8 /devel/p5-Test-LoadAllModules/Makefile
parent4742e57a8cc927707dd68cccc7adf69b9b64bb2a (diff)
downloadports-9bb0e048debf40a39170c467bd0786258876f51e.tar.gz
ports-9bb0e048debf40a39170c467bd0786258876f51e.zip
Notes
Diffstat (limited to 'devel/p5-Test-LoadAllModules/Makefile')
-rw-r--r--devel/p5-Test-LoadAllModules/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/p5-Test-LoadAllModules/Makefile b/devel/p5-Test-LoadAllModules/Makefile
new file mode 100644
index 000000000000..7fce8b05eb69
--- /dev/null
+++ b/devel/p5-Test-LoadAllModules/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: Test::LoadAllModules
+# Date created: 27 Feb 2009
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-LoadAllModules
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to do use_ok for modules in search path
+
+RUN_DEPENDS= \
+ p5-List-MoreUtils>0:${PORTSDIR}/lang/p5-List-MoreUtils
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::LoadAllModules.3
+
+.include <bsd.port.mk>