aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-LongString
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-02-14 14:52:53 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-02-14 14:52:53 +0000
commit4e75ae7282532d3230789a7fcb3aeea520b07eea (patch)
treebf26c40f7097d754ac33cf8436fdbfb3481f25a9 /devel/p5-Test-LongString
parent081a788e8834d3b7370f66fcbcd4d88d1ec906e1 (diff)
downloadports-4e75ae7282532d3230789a7fcb3aeea520b07eea.tar.gz
ports-4e75ae7282532d3230789a7fcb3aeea520b07eea.zip
Notes
Diffstat (limited to 'devel/p5-Test-LongString')
-rw-r--r--devel/p5-Test-LongString/Makefile28
-rw-r--r--devel/p5-Test-LongString/distinfo2
-rw-r--r--devel/p5-Test-LongString/pkg-descr7
-rw-r--r--devel/p5-Test-LongString/pkg-plist5
4 files changed, 42 insertions, 0 deletions
diff --git a/devel/p5-Test-LongString/Makefile b/devel/p5-Test-LongString/Makefile
new file mode 100644
index 000000000000..3cc25d95a5c3
--- /dev/null
+++ b/devel/p5-Test-LongString/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Test-LongString
+# Date created: 2004-04-26
+# Whom: aturetta@commit.it
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-LongString
+PORTVERSION= 0.07
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A library to test long strings
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::LongString.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-LongString/distinfo b/devel/p5-Test-LongString/distinfo
new file mode 100644
index 000000000000..1824ba906c95
--- /dev/null
+++ b/devel/p5-Test-LongString/distinfo
@@ -0,0 +1,2 @@
+MD5 (Test-LongString-0.07.tar.gz) = 61d60fb15578a57a7b2579f5ba391cf1
+SIZE (Test-LongString-0.07.tar.gz) = 5835
diff --git a/devel/p5-Test-LongString/pkg-descr b/devel/p5-Test-LongString/pkg-descr
new file mode 100644
index 000000000000..e650dd5e74b7
--- /dev/null
+++ b/devel/p5-Test-LongString/pkg-descr
@@ -0,0 +1,7 @@
+This module provides some drop-in replacements for the string comparison
+functions of Test::More, but which are more suitable when you test against
+long strings. If you've ever had to search for text in a multi-line string
+like an HTML document, or find specific items in binary data,
+this is the module for you.
+
+WWW: http://search.cpan.org/dist/Test-Cmd/
diff --git a/devel/p5-Test-LongString/pkg-plist b/devel/p5-Test-LongString/pkg-plist
new file mode 100644
index 000000000000..322ba307a980
--- /dev/null
+++ b/devel/p5-Test-LongString/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Test/LongString.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/LongString/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/LongString
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test 2>/dev/null || true