aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Manifest
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2004-10-27 12:28:35 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2004-10-27 12:28:35 +0000
commitde95ea51df78a3327c8818732612d7dd54ae241f (patch)
tree9755ae30545e82b573060fee56335a614b2d1223 /devel/p5-Test-Manifest
parent9cfb8ca626233e0d75dffe975648c8f7e3c1be72 (diff)
downloadports-de95ea51df78a3327c8818732612d7dd54ae241f.tar.gz
ports-de95ea51df78a3327c8818732612d7dd54ae241f.zip
Notes
Diffstat (limited to 'devel/p5-Test-Manifest')
-rw-r--r--devel/p5-Test-Manifest/Makefile3
-rw-r--r--devel/p5-Test-Manifest/distinfo4
-rw-r--r--devel/p5-Test-Manifest/files/5.005_03-lib::Manifest.pm22
3 files changed, 15 insertions, 14 deletions
diff --git a/devel/p5-Test-Manifest/Makefile b/devel/p5-Test-Manifest/Makefile
index 3805a78a3f59..3bfe435ccada 100644
--- a/devel/p5-Test-Manifest/Makefile
+++ b/devel/p5-Test-Manifest/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= Test-Manifest
-PORTVERSION= 0.93
-PORTREVISION= 1
+PORTVERSION= 1.11
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Test
diff --git a/devel/p5-Test-Manifest/distinfo b/devel/p5-Test-Manifest/distinfo
index 35d6603dbaf0..c2342ba337cd 100644
--- a/devel/p5-Test-Manifest/distinfo
+++ b/devel/p5-Test-Manifest/distinfo
@@ -1,2 +1,2 @@
-MD5 (Test-Manifest-0.93.tar.gz) = a46b6185410c2fd8b1a2efd6fea94d9e
-SIZE (Test-Manifest-0.93.tar.gz) = 3503
+MD5 (Test-Manifest-1.11.tar.gz) = 6191645d223be819120b540fdf2c6cc9
+SIZE (Test-Manifest-1.11.tar.gz) = 4534
diff --git a/devel/p5-Test-Manifest/files/5.005_03-lib::Manifest.pm b/devel/p5-Test-Manifest/files/5.005_03-lib::Manifest.pm
index bca7d2e95035..d8c9946b1574 100644
--- a/devel/p5-Test-Manifest/files/5.005_03-lib::Manifest.pm
+++ b/devel/p5-Test-Manifest/files/5.005_03-lib::Manifest.pm
@@ -1,33 +1,35 @@
---- lib/Manifest.pm.orig Fri Feb 20 20:11:18 2004
-+++ lib/Manifest.pm Sun Jun 6 16:35:27 2004
-@@ -102,17 +102,17 @@
+--- lib/Manifest.pm.orig Sun Sep 26 03:42:46 2004
++++ lib/Manifest.pm Wed Oct 27 16:25:38 2004
+@@ -135,11 +135,11 @@
sub get_t_files()
{
carp( "$Manifest does not exist!" ) unless -e $Manifest;
- return unless open my( $fh ), $Manifest;
+ return unless open FH, $Manifest;
-
+
my @tests = ();
-
+
- while( <$fh> )
+ while( <FH> )
{
chomp;
+ s/^\s+|\s+$//g;
+@@ -147,7 +147,7 @@
carp( "test file begins with t/ [$_]" ) if m|^t/|;
- push @tests, "t/$_" if -e "t/$_";
+ push @tests, catfile( "t", $_ ) if -e catfile( "t", $_ );
}
- close $fh;
+ close FH;
-
+
return wantarray ? @tests : join " ", @tests;
}
-@@ -131,16 +131,16 @@
+@@ -166,16 +166,16 @@
sub make_test_manifest()
{
carp( "t/ directory does not exist!" ) unless -d "t";
- return unless open my( $fh ), "> $Manifest";
+ return unless open FH, "> $Manifest";
-
+
my $count = 0;
while( my $file = glob("t/*.t") )
{
@@ -38,6 +40,6 @@
}
- close $fh;
+ close FH;
-
+
return $count;
}