aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Manifest
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2004-11-04 09:22:40 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2004-11-04 09:22:40 +0000
commit613dabc89373a8e4343bb24fbae78eab73d55fbd (patch)
tree680fd6c44f76476c3e48040b5cf73f44de83d5ee /devel/p5-Test-Manifest
parent6c3a9c4f9505a2280b1e5d30fcda0951d7de20fb (diff)
downloadports-613dabc89373a8e4343bb24fbae78eab73d55fbd.tar.gz
ports-613dabc89373a8e4343bb24fbae78eab73d55fbd.zip
Notes
Diffstat (limited to 'devel/p5-Test-Manifest')
-rw-r--r--devel/p5-Test-Manifest/Makefile6
-rw-r--r--devel/p5-Test-Manifest/files/5.005_03-lib::Manifest.pm45
2 files changed, 4 insertions, 47 deletions
diff --git a/devel/p5-Test-Manifest/Makefile b/devel/p5-Test-Manifest/Makefile
index 3bfe435ccada..383d71405ddf 100644
--- a/devel/p5-Test-Manifest/Makefile
+++ b/devel/p5-Test-Manifest/Makefile
@@ -20,7 +20,9 @@ PERL_CONFIGURE= YES
MAN3= Test::Manifest.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} <= 500503
-EXTRA_PATCHES= ${FILESDIR}/5.005_03-lib::Manifest.pm
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= Requires perl 5.6.1 or above
.endif
+
.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Manifest/files/5.005_03-lib::Manifest.pm b/devel/p5-Test-Manifest/files/5.005_03-lib::Manifest.pm
deleted file mode 100644
index d8c9946b1574..000000000000
--- a/devel/p5-Test-Manifest/files/5.005_03-lib::Manifest.pm
+++ /dev/null
@@ -1,45 +0,0 @@
---- lib/Manifest.pm.orig Sun Sep 26 03:42:46 2004
-+++ lib/Manifest.pm Wed Oct 27 16:25:38 2004
-@@ -135,11 +135,11 @@
- sub get_t_files()
- {
- carp( "$Manifest does not exist!" ) unless -e $Manifest;
-- return unless open my( $fh ), $Manifest;
-+ return unless open FH, $Manifest;
-
- my @tests = ();
-
-- while( <$fh> )
-+ while( <FH> )
- {
- chomp;
- s/^\s+|\s+$//g;
-@@ -147,7 +147,7 @@
- carp( "test file begins with t/ [$_]" ) if m|^t/|;
- push @tests, catfile( "t", $_ ) if -e catfile( "t", $_ );
- }
-- close $fh;
-+ close FH;
-
- return wantarray ? @tests : join " ", @tests;
- }
-@@ -166,16 +166,16 @@
- sub make_test_manifest()
- {
- carp( "t/ directory does not exist!" ) unless -d "t";
-- return unless open my( $fh ), "> $Manifest";
-+ return unless open FH, "> $Manifest";
-
- my $count = 0;
- while( my $file = glob("t/*.t") )
- {
- $file =~ s|^t/||;
-- print $fh "$file\n";
-+ print FH "$file\n";
- $count++;
- }
-- close $fh;
-+ close FH;
-
- return $count;
- }