aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Output
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-19 08:04:17 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-19 08:04:17 +0000
commit485a228c0a26c2687ee923aad99888b0393d912a (patch)
treeec795dae325cbddd8af8e660590d39d8a0f714d2 /devel/p5-Test-Output
parent85d80c676722468d7290f3babd3007f6f7fbbbad (diff)
downloadports-485a228c0a26c2687ee923aad99888b0393d912a.tar.gz
ports-485a228c0a26c2687ee923aad99888b0393d912a.zip
Notes
Diffstat (limited to 'devel/p5-Test-Output')
-rw-r--r--devel/p5-Test-Output/Makefile31
-rw-r--r--devel/p5-Test-Output/distinfo3
-rw-r--r--devel/p5-Test-Output/pkg-descr11
-rw-r--r--devel/p5-Test-Output/pkg-plist8
4 files changed, 53 insertions, 0 deletions
diff --git a/devel/p5-Test-Output/Makefile b/devel/p5-Test-Output/Makefile
new file mode 100644
index 000000000000..3a86b73f1733
--- /dev/null
+++ b/devel/p5-Test-Output/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Test-Output
+# Date created: 2006-07-19
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Output
+PORTVERSION= 0.10
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Utilities to test STDOUT and STDERR messages
+
+RUN_DEPENDS= ${SITE_PERL}/Sub/Exporter.pm:${PORTSDIR}/devel/p5-Sub-Exporter \
+ ${SITE_PERL}/Test/Tester.pm:${PORTSDIR}/devel/p5-Test-Tester
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Output::Tie.3 Test::Output.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800 # Inherited from devel/p5-Sub-Exporter
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Output/distinfo b/devel/p5-Test-Output/distinfo
new file mode 100644
index 000000000000..010f123c5369
--- /dev/null
+++ b/devel/p5-Test-Output/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Output-0.10.tar.gz) = dcf67296e04a41a9f73f70c10fe5f825
+SHA256 (Test-Output-0.10.tar.gz) = b72813be2639d49dda2a3f87928b7ce185633f3afaa25300afbfb844b12deea4
+SIZE (Test-Output-0.10.tar.gz) = 9838
diff --git a/devel/p5-Test-Output/pkg-descr b/devel/p5-Test-Output/pkg-descr
new file mode 100644
index 000000000000..011e239fb9b0
--- /dev/null
+++ b/devel/p5-Test-Output/pkg-descr
@@ -0,0 +1,11 @@
+Test::Output provides a simple interface for testing output sent to
+STDOUT or STDERR. A number of different utilies are included to try
+and be as flexible as possible to the tester.
+
+Originally this module was designed not to have external requirements,
+however, the features provided by Sub::Exporter over what Exporter
+provides is just to great to pass up.
+
+Test::Output ties STDOUT and STDERR using Test::Output::Tie.
+
+WWW: http://search.cpan.org/dist/Test-Output/
diff --git a/devel/p5-Test-Output/pkg-plist b/devel/p5-Test-Output/pkg-plist
new file mode 100644
index 000000000000..624bc97c630b
--- /dev/null
+++ b/devel/p5-Test-Output/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Output/.packlist
+%%SITE_PERL%%/Test/Output.pm
+%%SITE_PERL%%/Test/Output/Tie.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Output
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test/Output
+@dirrmtry %%SITE_PERL%%/Test