aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Pod
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-07-02 18:03:16 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-07-02 18:03:16 +0000
commit86118766e69af1a1ad07a6aef5c4198957ffe505 (patch)
tree401857152c72f30316d32e3bc729e8428caa998e /devel/p5-Test-Pod
parentfd22f4947016f35aa085ed3d965c1db74ae0571c (diff)
downloadports-86118766e69af1a1ad07a6aef5c4198957ffe505.tar.gz
ports-86118766e69af1a1ad07a6aef5c4198957ffe505.zip
Notes
Diffstat (limited to 'devel/p5-Test-Pod')
-rw-r--r--devel/p5-Test-Pod/Makefile28
-rw-r--r--devel/p5-Test-Pod/distinfo1
-rw-r--r--devel/p5-Test-Pod/pkg-descr4
-rw-r--r--devel/p5-Test-Pod/pkg-plist5
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/p5-Test-Pod/Makefile b/devel/p5-Test-Pod/Makefile
new file mode 100644
index 000000000000..1e88d6fbe9eb
--- /dev/null
+++ b/devel/p5-Test-Pod/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Test-Pod
+# Date created: 2 july 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Pod
+PORTVERSION= 0.95
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Check for POD errors in files
+
+BUILD_DEPENDS= ${SITE_PERL}/IO/Scalar.pm:${PORTSDIR}/devel/p5-IO-stringy \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester \
+ ${SITE_PERL}/Pod/Simple.pm:${PORTSDIR}/textproc/p5-Pod-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Pod.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Pod/distinfo b/devel/p5-Test-Pod/distinfo
new file mode 100644
index 000000000000..c593936744a1
--- /dev/null
+++ b/devel/p5-Test-Pod/distinfo
@@ -0,0 +1 @@
+MD5 (Test-Pod-0.95.tar.gz) = 6b2a233f5f443f5b5789a5cca449d4f4
diff --git a/devel/p5-Test-Pod/pkg-descr b/devel/p5-Test-Pod/pkg-descr
new file mode 100644
index 000000000000..d4b3a6dadebf
--- /dev/null
+++ b/devel/p5-Test-Pod/pkg-descr
@@ -0,0 +1,4 @@
+Check POD files for errors or warnings in a test file, using Pod::Simple to do
+the heavy lifting.
+
+WWW: http://search.cpan.org/dist/Test-Pod/
diff --git a/devel/p5-Test-Pod/pkg-plist b/devel/p5-Test-Pod/pkg-plist
new file mode 100644
index 000000000000..b64a05db7a67
--- /dev/null
+++ b/devel/p5-Test-Pod/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Test/Pod.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Pod/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Pod
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test 2>/dev/null || true