aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Refcount
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-28 09:18:26 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-28 09:18:26 +0000
commit31d03d8d7dcc0566fedde8b983affd5c2aa4c163 (patch)
tree11ecb35207103abd2ba9c597181b47b1afa71889 /devel/p5-Test-Refcount
parenta8d190bb13bdc7df91b8231ecfd9c059b698af92 (diff)
Notes
Diffstat (limited to 'devel/p5-Test-Refcount')
-rw-r--r--devel/p5-Test-Refcount/Makefile21
-rw-r--r--devel/p5-Test-Refcount/distinfo2
-rw-r--r--devel/p5-Test-Refcount/pkg-descr16
-rw-r--r--devel/p5-Test-Refcount/pkg-plist5
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/p5-Test-Refcount/Makefile b/devel/p5-Test-Refcount/Makefile
new file mode 100644
index 000000000000..387da031965e
--- /dev/null
+++ b/devel/p5-Test-Refcount/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Test-Refcount
+# Date created: 2011-11-28
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Refcount
+PORTVERSION= 0.07
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Assert reference counts on objects
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Refcount.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Refcount/distinfo b/devel/p5-Test-Refcount/distinfo
new file mode 100644
index 000000000000..18046de3f957
--- /dev/null
+++ b/devel/p5-Test-Refcount/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Test-Refcount-0.07.tar.gz) = 8be880d8e6bc946c79145fe1bd3fedd51c1c168785e4fb939fff41764201b511
+SIZE (Test-Refcount-0.07.tar.gz) = 15953
diff --git a/devel/p5-Test-Refcount/pkg-descr b/devel/p5-Test-Refcount/pkg-descr
new file mode 100644
index 000000000000..3025765dd6c3
--- /dev/null
+++ b/devel/p5-Test-Refcount/pkg-descr
@@ -0,0 +1,16 @@
+The Perl garbage collector uses simple reference counting during the normal
+execution of a program. This means that cycles or unweakened references in other
+parts of code can keep an object around for longer than intended. To help avoid
+this problem, the reference count of a new object from its class constructor
+ought to be 1. This way, the caller can know the object will be properly
+DESTROYed when it drops all of its references to it.
+
+Test::Refcount provides two test functions to help ensure this property holds
+for an object class, so as to be polite to its callers.
+
+If the assertion fails; that is, if the actual reference count is different to
+what was expected, a trace of references to the object can be printed, if Marc
+Lehmann's Devel::FindRef module is installed. This may assist the developer in
+finding where the references are.
+
+WWW: http://search.cpan.org/dist/Test-Refcount/
diff --git a/devel/p5-Test-Refcount/pkg-plist b/devel/p5-Test-Refcount/pkg-plist
new file mode 100644
index 000000000000..775f38524be2
--- /dev/null
+++ b/devel/p5-Test-Refcount/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Test/Refcount.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Refcount/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Refcount
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test