aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Spec/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-09-10 06:40:55 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-09-10 06:40:55 +0000
commit91f015d0af02dc8f2e07e95ee87a4aba079ed5f8 (patch)
treec35ac05277990011a0bc28bfc88fd3fbb181d551 /devel/p5-Test-Spec/Makefile
parent3e4882176ae61cf2f4b02d11e0ef3c6d13b0cd56 (diff)
Notes
Diffstat (limited to 'devel/p5-Test-Spec/Makefile')
-rw-r--r--devel/p5-Test-Spec/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/p5-Test-Spec/Makefile b/devel/p5-Test-Spec/Makefile
new file mode 100644
index 000000000000..6cfaad3e834e
--- /dev/null
+++ b/devel/p5-Test-Spec/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Test-Spec
+# Date created: 2011-09-10
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Spec
+PORTVERSION= 0.39
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Write tests in a declarative specification style
+
+BUILD_DEPENDS= p5-Package-Stash>=0.23:${PORTSDIR}/devel/p5-Package-Stash \
+ p5-Test-Deep>=0.103:${PORTSDIR}/devel/p5-Test-Deep \
+ p5-Test-Trap>=0:${PORTSDIR}/devel/p5-Test-Trap \
+ p5-Tie-IxHash>=0:${PORTSDIR}/devel/p5-Tie-IxHash
+RUN_DEPENDS= p5-Package-Stash>=0.23:${PORTSDIR}/devel/p5-Package-Stash \
+ p5-Test-Deep>=0.103:${PORTSDIR}/devel/p5-Test-Deep \
+ p5-Test-Trap>=0:${PORTSDIR}/devel/p5-Test-Trap \
+ p5-Tie-IxHash>=0:${PORTSDIR}/devel/p5-Tie-IxHash
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Spec.3 \
+ Test::Spec::Mocks.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= Test-Harness>=0:${PORTSDIR}/devel/p5-Test-Harness
+.endif
+
+.include <bsd.port.post.mk>