aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-SubCalls
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-10-13 12:04:15 +0000
committerLars Thegler <lth@FreeBSD.org>2005-10-13 12:04:15 +0000
commit13348f462cacf4ff4c1f63d12ac0afa3792eb5c2 (patch)
tree508cd824d9fe342475a9c90cb8a32100c75bac06 /devel/p5-Test-SubCalls
parent0d8aabc158c7485c1778851470ac81707cc33a04 (diff)
downloadports-13348f462cacf4ff4c1f63d12ac0afa3792eb5c2.tar.gz
ports-13348f462cacf4ff4c1f63d12ac0afa3792eb5c2.zip
Notes
Diffstat (limited to 'devel/p5-Test-SubCalls')
-rw-r--r--devel/p5-Test-SubCalls/Makefile35
-rw-r--r--devel/p5-Test-SubCalls/distinfo2
-rw-r--r--devel/p5-Test-SubCalls/pkg-descr6
-rw-r--r--devel/p5-Test-SubCalls/pkg-plist5
4 files changed, 48 insertions, 0 deletions
diff --git a/devel/p5-Test-SubCalls/Makefile b/devel/p5-Test-SubCalls/Makefile
new file mode 100644
index 000000000000..775ec15f1675
--- /dev/null
+++ b/devel/p5-Test-SubCalls/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: devel/p5-Test-SubCalls
+# Date created: 08 October 2005
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-SubCalls
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Track the number of times subs are called
+
+BUILD_DEPENDS= ${SITE_PERL}/Hook/LexWrap.pm:${PORTSDIR}/devel/p5-Hook-LexWrap \
+ ${SITE_PERL}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::SubCalls.3
+
+post-patch:
+ @${RM} ${WRKSRC}/inc/Module/Install/AutoInstall.pm
+ @${PERL} -pi -e '$$_="" if m/AutoInstall/' ${WRKSRC}/MANIFEST
+ @${PERL} -pi -e '$$_="" if m/Test::More|auto_install/' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500601 # inherited from devel/p5-Hook-LexWrap
+IGNORE= requires perl 5.6.1 or newer. Install lang/perl5 or lang/perl5.8 and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-SubCalls/distinfo b/devel/p5-Test-SubCalls/distinfo
new file mode 100644
index 000000000000..75c27e0a398f
--- /dev/null
+++ b/devel/p5-Test-SubCalls/distinfo
@@ -0,0 +1,2 @@
+MD5 (Test-SubCalls-0.01.tar.gz) = 02a2eeeadc9f94e2998389716a1545b9
+SIZE (Test-SubCalls-0.01.tar.gz) = 26026
diff --git a/devel/p5-Test-SubCalls/pkg-descr b/devel/p5-Test-SubCalls/pkg-descr
new file mode 100644
index 000000000000..730db514ccd3
--- /dev/null
+++ b/devel/p5-Test-SubCalls/pkg-descr
@@ -0,0 +1,6 @@
+There are a number of different situations (like testing cacheing code)
+where you want to want to do a number of tests, and then verify that
+some underlying subroutine deep within the code was called a specific
+number of times.
+
+WWW: http://search.cpan.org/dist/Test-SubCalls/
diff --git a/devel/p5-Test-SubCalls/pkg-plist b/devel/p5-Test-SubCalls/pkg-plist
new file mode 100644
index 000000000000..85da2167bf25
--- /dev/null
+++ b/devel/p5-Test-SubCalls/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Test/SubCalls.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/SubCalls/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/SubCalls
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test 2>/dev/null || true