aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-Trap
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-09-10 06:38:16 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-09-10 06:38:16 +0000
commit3e4882176ae61cf2f4b02d11e0ef3c6d13b0cd56 (patch)
treefa797785f8901e1eecb7e1717a3203f5066b57b8 /devel/p5-Test-Trap
parent4769c4d06eea1ff2f79e5bc7a70ed8b14800c912 (diff)
Notes
Diffstat (limited to 'devel/p5-Test-Trap')
-rw-r--r--devel/p5-Test-Trap/Makefile42
-rw-r--r--devel/p5-Test-Trap/distinfo2
-rw-r--r--devel/p5-Test-Trap/pkg-descr9
-rw-r--r--devel/p5-Test-Trap/pkg-plist11
4 files changed, 64 insertions, 0 deletions
diff --git a/devel/p5-Test-Trap/Makefile b/devel/p5-Test-Trap/Makefile
new file mode 100644
index 000000000000..150e661a57fe
--- /dev/null
+++ b/devel/p5-Test-Trap/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: p5-Test-Trap
+# Date created: 2011-09-10
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Trap
+PORTVERSION= 0.2.1
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Trap exit codes, exceptions, output, etc
+
+BUILD_DEPENDS= p5-Data-Dump>=0:${PORTSDIR}/devel/p5-Data-Dump
+RUN_DEPENDS= p5-Data-Dump>=0:${PORTSDIR}/devel/p5-Data-Dump
+
+TEST_DEPENDS= p5-Test-Tester>=0.10.7:${PORTSDIR}/devel/p5-Test-Tester
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Trap.3 \
+ Test::Trap::Builder.3 \
+ Test::Trap::Builder::PerlIO.3 \
+ Test::Trap::Builder::SystemSafe.3 \
+ Test::Trap::Builder::TempFile.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+BUILD_DEPENDS+= p5-version>=0:${PORTSDIR}/devel/p5-version
+RUN_DEPENDS+= p5-version>=0:${PORTSDIR}/devel/p5-version
+.endif
+
+#.if ${PERL_LEVEL} < 501200
+#BUILD_DEPENDS+= p5-Module-Build>=0.3500:${PORTSDIR}/devel/p5-Module-Build
+#.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Trap/distinfo b/devel/p5-Test-Trap/distinfo
new file mode 100644
index 000000000000..49ed7aba2f7a
--- /dev/null
+++ b/devel/p5-Test-Trap/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Test-Trap-v0.2.1.tar.gz) = 944a1cfdecdde0715f584fd8f05635a29b9a45a9277ffd271d8c5ddc5b1f13db
+SIZE (Test-Trap-v0.2.1.tar.gz) = 45622
diff --git a/devel/p5-Test-Trap/pkg-descr b/devel/p5-Test-Trap/pkg-descr
new file mode 100644
index 000000000000..ef4d84611d39
--- /dev/null
+++ b/devel/p5-Test-Trap/pkg-descr
@@ -0,0 +1,9 @@
+Test::Trap is primarily (but not exclusively) for use in test scripts: a block
+eval on steroids, configurable and extensible, but by default trapping (Perl)
+STDOUT, STDERR, warnings, exceptions, would-be exit codes, and return values
+from boxed blocks of test code.
+
+The values collected by the latest trap can then be queried or tested through a
+special trap object.
+
+WWW: http://search.cpan.org/dist/Test-Trap/
diff --git a/devel/p5-Test-Trap/pkg-plist b/devel/p5-Test-Trap/pkg-plist
new file mode 100644
index 000000000000..082b1eac538d
--- /dev/null
+++ b/devel/p5-Test-Trap/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Test/Trap.pm
+%%SITE_PERL%%/Test/Trap/Builder.pm
+%%SITE_PERL%%/Test/Trap/Builder/PerlIO.pm
+%%SITE_PERL%%/Test/Trap/Builder/SystemSafe.pm
+%%SITE_PERL%%/Test/Trap/Builder/TempFile.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Trap/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Trap
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrm %%SITE_PERL%%/Test/Trap/Builder
+@dirrm %%SITE_PERL%%/Test/Trap
+@dirrmtry %%SITE_PERL%%/Test