aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-WWW-Mechanize-CGIApp
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-21 20:48:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-21 20:48:41 +0000
commit89102a6fba425465ae7f1e94c6882d35061a246e (patch)
tree0ae06e1cd7d70901eceba1e899758066fb2574cf /devel/p5-Test-WWW-Mechanize-CGIApp
parent5c52aa712570a0c285785ca446cf5d1a7da4b060 (diff)
downloadports-89102a6fba425465ae7f1e94c6882d35061a246e.tar.gz
ports-89102a6fba425465ae7f1e94c6882d35061a246e.zip
Notes
Diffstat (limited to 'devel/p5-Test-WWW-Mechanize-CGIApp')
-rw-r--r--devel/p5-Test-WWW-Mechanize-CGIApp/Makefile26
-rw-r--r--devel/p5-Test-WWW-Mechanize-CGIApp/distinfo3
-rw-r--r--devel/p5-Test-WWW-Mechanize-CGIApp/pkg-descr13
-rw-r--r--devel/p5-Test-WWW-Mechanize-CGIApp/pkg-plist9
4 files changed, 51 insertions, 0 deletions
diff --git a/devel/p5-Test-WWW-Mechanize-CGIApp/Makefile b/devel/p5-Test-WWW-Mechanize-CGIApp/Makefile
new file mode 100644
index 000000000000..3ba3ac9fcac8
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize-CGIApp/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: p5-Test-WWW-Mechanize-CGIApp
+# Date created: September 01, 2008
+# Whom: George Hartzell <hartzell@alerce.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-WWW-Mechanize-CGIApp
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hartzell@alerce.com
+COMMENT= Test::WWW::Mechanize for CGIApp
+
+RUN_DEPENDS= p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application \
+ p5-Test-WWW-Mechanize>=1.14:${PORTSDIR}/devel/p5-Test-WWW-Mechanize \
+ p5-HTTP-Request-AsCGI>=0:${PORTSDIR}/www/p5-HTTP-Request-AsCGI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= 5.8.1+
+
+MAN3= Test::WWW::Mechanize::CGIApp.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-WWW-Mechanize-CGIApp/distinfo b/devel/p5-Test-WWW-Mechanize-CGIApp/distinfo
new file mode 100644
index 000000000000..9f766b7ae284
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize-CGIApp/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-WWW-Mechanize-CGIApp-0.05.tar.gz) = fba006e9c9d5591f341cefb44a178429
+SHA256 (Test-WWW-Mechanize-CGIApp-0.05.tar.gz) = 07149ca962d9eb922dfd0615b0402502b4b6092242ba345fe3ccbb35f882c5d4
+SIZE (Test-WWW-Mechanize-CGIApp-0.05.tar.gz) = 13289
diff --git a/devel/p5-Test-WWW-Mechanize-CGIApp/pkg-descr b/devel/p5-Test-WWW-Mechanize-CGIApp/pkg-descr
new file mode 100644
index 000000000000..76930eec4577
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize-CGIApp/pkg-descr
@@ -0,0 +1,13 @@
+Test::WWW::Mechanize is a subclass of WWW::Mechanize that incorporates
+features for web application testing. The Test::WWW::Mechanize::Catalyst
+module meshes the two to allow easy testing of Catalyst applications
+without starting up a web server.
+
+Testing web applications has always been a bit tricky, normally starting
+a web server for your application and making real HTTP requests to it.
+This module allows you to test Catalyst web applications but does not
+start a server or issue HTTP requests. Instead, it passes the HTTP
+request object directly to Catalyst. Thus you do not need to use a real
+hostname: "http://localhost/" will do.
+
+WWW: http://search.cpan.org/dist/Test-WWW-Mechanize-Catalyst/
diff --git a/devel/p5-Test-WWW-Mechanize-CGIApp/pkg-plist b/devel/p5-Test-WWW-Mechanize-CGIApp/pkg-plist
new file mode 100644
index 000000000000..45938ddf5d62
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize-CGIApp/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Test/WWW/Mechanize/CGIApp.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/WWW/Mechanize/CGIApp/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/WWW/Mechanize/CGIApp
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/WWW/Mechanize
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/WWW
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test/WWW/Mechanize
+@dirrmtry %%SITE_PERL%%/Test/WWW
+@dirrmtry %%SITE_PERL%%/Test