aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-WWW-Mechanize
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-02-14 15:22:14 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-02-14 15:22:14 +0000
commit0512dd2a1df7e2a8ed6972c4663cb8339c8180b3 (patch)
tree983573939f0f5ef462687f3c85ba3375012a9c39 /devel/p5-Test-WWW-Mechanize
parent374481a3c31167a9ddca580a476f098a3a4a9097 (diff)
downloadports-0512dd2a1df7e2a8ed6972c4663cb8339c8180b3.tar.gz
ports-0512dd2a1df7e2a8ed6972c4663cb8339c8180b3.zip
Notes
Diffstat (limited to 'devel/p5-Test-WWW-Mechanize')
-rw-r--r--devel/p5-Test-WWW-Mechanize/Makefile35
-rw-r--r--devel/p5-Test-WWW-Mechanize/distinfo2
-rw-r--r--devel/p5-Test-WWW-Mechanize/pkg-descr4
-rw-r--r--devel/p5-Test-WWW-Mechanize/pkg-plist7
4 files changed, 48 insertions, 0 deletions
diff --git a/devel/p5-Test-WWW-Mechanize/Makefile b/devel/p5-Test-WWW-Mechanize/Makefile
new file mode 100644
index 000000000000..4fe381b5d00c
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-WWW-Mechanize
+# Date created: 2005-02-13
+# Whom: aturetta@commit.it
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-WWW-Mechanize
+PORTVERSION= 1.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Testing-specific WWW::Mechanize subclass
+
+BUILD_DEPENDS= ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize \
+ ${SITE_PERL}/Test/LongString.pm:${PORTSDIR}/devel/p5-Test-LongString
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::WWW::Mechanize.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/Test/Builder.pm:${PORTSDIR}/devel/p5-Test-Simple
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-WWW-Mechanize/distinfo b/devel/p5-Test-WWW-Mechanize/distinfo
new file mode 100644
index 000000000000..92eac28efb3b
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize/distinfo
@@ -0,0 +1,2 @@
+MD5 (Test-WWW-Mechanize-1.02.tar.gz) = cf36b040879dd1053696b565fe16839b
+SIZE (Test-WWW-Mechanize-1.02.tar.gz) = 6191
diff --git a/devel/p5-Test-WWW-Mechanize/pkg-descr b/devel/p5-Test-WWW-Mechanize/pkg-descr
new file mode 100644
index 000000000000..1f44f476eafa
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize/pkg-descr
@@ -0,0 +1,4 @@
+Test::WWW::Mechanize is a subclass of WWW::Mechanize that incorporates
+features for web application testing.
+
+WWW: http://search.cpan.org/dist/Test-WWW-Mechanize/
diff --git a/devel/p5-Test-WWW-Mechanize/pkg-plist b/devel/p5-Test-WWW-Mechanize/pkg-plist
new file mode 100644
index 000000000000..840da9b7293c
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Test/WWW/Mechanize.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/WWW/Mechanize/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/WWW/Mechanize
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/WWW 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test/WWW 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test 2>/dev/null || true