aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-YAML-Valid
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2007-04-10 07:17:27 +0000
committerLars Thegler <lth@FreeBSD.org>2007-04-10 07:17:27 +0000
commitdd9689075873677673fe7d8f3ca49f6b2c1a6617 (patch)
tree4f616f7200771040e2d4aa769dbe34089061ab8b /devel/p5-Test-YAML-Valid
parent458ecf0b6b99ffb48f1ae04ceaecdde1927d67ec (diff)
downloadports-dd9689075873677673fe7d8f3ca49f6b2c1a6617.tar.gz
ports-dd9689075873677673fe7d8f3ca49f6b2c1a6617.zip
Notes
Diffstat (limited to 'devel/p5-Test-YAML-Valid')
-rw-r--r--devel/p5-Test-YAML-Valid/Makefile26
-rw-r--r--devel/p5-Test-YAML-Valid/distinfo3
-rw-r--r--devel/p5-Test-YAML-Valid/pkg-descr3
-rw-r--r--devel/p5-Test-YAML-Valid/pkg-plist7
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/p5-Test-YAML-Valid/Makefile b/devel/p5-Test-YAML-Valid/Makefile
new file mode 100644
index 000000000000..520aa578d013
--- /dev/null
+++ b/devel/p5-Test-YAML-Valid/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: devel/p5-Test-YAML-Valid
+# Date created: 10 April 2007
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-YAML-Valid
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Test for valid YAML
+
+RUN_DEPENDS= p5-YAML>=0.60:${PORTSDIR}/textproc/p5-YAML \
+ p5-Test-Simple>0:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::YAML::Valid.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-YAML-Valid/distinfo b/devel/p5-Test-YAML-Valid/distinfo
new file mode 100644
index 000000000000..1c5f5a700e18
--- /dev/null
+++ b/devel/p5-Test-YAML-Valid/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-YAML-Valid-0.03.tar.gz) = ef76bf8995f8165253d58a29d77da8e8
+SHA256 (Test-YAML-Valid-0.03.tar.gz) = c5944ce73c3e697e3ad465ab08448db6368b019b8f3908755dbff90862814230
+SIZE (Test-YAML-Valid-0.03.tar.gz) = 26435
diff --git a/devel/p5-Test-YAML-Valid/pkg-descr b/devel/p5-Test-YAML-Valid/pkg-descr
new file mode 100644
index 000000000000..e90f525cccc4
--- /dev/null
+++ b/devel/p5-Test-YAML-Valid/pkg-descr
@@ -0,0 +1,3 @@
+This module lets you easily test the validity of YAML.
+
+WWW: http://search.cpan.org/dist/Test-YAML-Valid/
diff --git a/devel/p5-Test-YAML-Valid/pkg-plist b/devel/p5-Test-YAML-Valid/pkg-plist
new file mode 100644
index 000000000000..c3ab5d87c45d
--- /dev/null
+++ b/devel/p5-Test-YAML-Valid/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Test/YAML/Valid.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/YAML/Valid/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/YAML/Valid
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/YAML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test/YAML
+@dirrmtry %%SITE_PERL%%/Test