aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-TheSchwartz/Makefile
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2008-01-14 01:15:02 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2008-01-14 01:15:02 +0000
commitc5ea6bf540e76ab4cd555e152500e268beb0832d (patch)
tree754d5131d65769a35de89dfc067e33ac3c25f3fe /devel/p5-TheSchwartz/Makefile
parentf064527d9f5b57fcd238b859e717c7ee339f1294 (diff)
downloadports-c5ea6bf540e76ab4cd555e152500e268beb0832d.tar.gz
ports-c5ea6bf540e76ab4cd555e152500e268beb0832d.zip
Notes
Diffstat (limited to 'devel/p5-TheSchwartz/Makefile')
-rw-r--r--devel/p5-TheSchwartz/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/p5-TheSchwartz/Makefile b/devel/p5-TheSchwartz/Makefile
new file mode 100644
index 000000000000..56ec819fbbdc
--- /dev/null
+++ b/devel/p5-TheSchwartz/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-TheSchwartz
+# Date created: 2008-01-11
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= TheSchwartz
+PORTVERSION= 1.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/B/BR/BRADFITZ
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Reliable job queue
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/Data/ObjectDriver.pm:${PORTSDIR}/devel/p5-Data-ObjectDriver
+
+PERL_CONFIGURE= yes
+
+MAN3= TheSchwartz.3 TheSchwartz::Job.3 TheSchwartz::Worker.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>