aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-TheSchwartz
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2008-01-14 01:15:02 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2008-01-14 01:15:02 +0000
commitc5ea6bf540e76ab4cd555e152500e268beb0832d (patch)
tree754d5131d65769a35de89dfc067e33ac3c25f3fe /devel/p5-TheSchwartz
parentf064527d9f5b57fcd238b859e717c7ee339f1294 (diff)
Notes
Diffstat (limited to 'devel/p5-TheSchwartz')
-rw-r--r--devel/p5-TheSchwartz/Makefile31
-rw-r--r--devel/p5-TheSchwartz/distinfo3
-rw-r--r--devel/p5-TheSchwartz/pkg-descr6
-rw-r--r--devel/p5-TheSchwartz/pkg-plist11
4 files changed, 51 insertions, 0 deletions
diff --git a/devel/p5-TheSchwartz/Makefile b/devel/p5-TheSchwartz/Makefile
new file mode 100644
index 000000000000..56ec819fbbdc
--- /dev/null
+++ b/devel/p5-TheSchwartz/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-TheSchwartz
+# Date created: 2008-01-11
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= TheSchwartz
+PORTVERSION= 1.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/B/BR/BRADFITZ
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Reliable job queue
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/Data/ObjectDriver.pm:${PORTSDIR}/devel/p5-Data-ObjectDriver
+
+PERL_CONFIGURE= yes
+
+MAN3= TheSchwartz.3 TheSchwartz::Job.3 TheSchwartz::Worker.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-TheSchwartz/distinfo b/devel/p5-TheSchwartz/distinfo
new file mode 100644
index 000000000000..db4fa0d0dcdc
--- /dev/null
+++ b/devel/p5-TheSchwartz/distinfo
@@ -0,0 +1,3 @@
+MD5 (TheSchwartz-1.04.tar.gz) = f750525972485e69c8a08d4a45f51247
+SHA256 (TheSchwartz-1.04.tar.gz) = b5d15d84db2f4f70e008ee66b2be32e57136bd891bafbe4c91957e153eea1aad
+SIZE (TheSchwartz-1.04.tar.gz) = 44656
diff --git a/devel/p5-TheSchwartz/pkg-descr b/devel/p5-TheSchwartz/pkg-descr
new file mode 100644
index 000000000000..d2e5c2321fd6
--- /dev/null
+++ b/devel/p5-TheSchwartz/pkg-descr
@@ -0,0 +1,6 @@
+TheSchwartz is a reliable job queue system. Your application can put
+jobs into the system, and your worker processes can pull jobs from the
+queue atomically to perform. Failed jobs can be left in the queue to
+retry later.
+
+WWW: http://search.cpan.org/dist/TheSchwartz/
diff --git a/devel/p5-TheSchwartz/pkg-plist b/devel/p5-TheSchwartz/pkg-plist
new file mode 100644
index 000000000000..9425ddbb5fae
--- /dev/null
+++ b/devel/p5-TheSchwartz/pkg-plist
@@ -0,0 +1,11 @@
+bin/schwartzmon
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/TheSchwartz/.packlist
+%%SITE_PERL%%/TheSchwartz.pm
+%%SITE_PERL%%/TheSchwartz/Error.pm
+%%SITE_PERL%%/TheSchwartz/ExitStatus.pm
+%%SITE_PERL%%/TheSchwartz/FuncMap.pm
+%%SITE_PERL%%/TheSchwartz/Job.pm
+%%SITE_PERL%%/TheSchwartz/JobHandle.pm
+%%SITE_PERL%%/TheSchwartz/Worker.pm
+@dirrmtry %%SITE_PERL%%/TheSchwartz
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/TheSchwartz