aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Thread-Cancel/Makefile
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-01-12 19:52:07 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-01-12 19:52:07 +0000
commit8489fe22d333952f1ac899f5b051868bfc391990 (patch)
tree3029f86f9e46723e7bc39e602ccece541e45f41b /devel/p5-Thread-Cancel/Makefile
parent6199e7562db40beff5a2def1f84167b96e94e6bc (diff)
This module adds cancellation capabilities for threads. Cancelled
threads are terminated using threads->exit(). The thread is then detached, and hence automatically cleaned up. Threads that are suspended using Thread::Suspend do not need to be resumed in order to be cancelled. It is possible for a thread to cancel itself. PR: ports/110475 Submitted by: Ruben van Staveren <ruben@verweg.com>
Notes
Notes: svn path=/head/; revision=225869
Diffstat (limited to 'devel/p5-Thread-Cancel/Makefile')
-rw-r--r--devel/p5-Thread-Cancel/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/p5-Thread-Cancel/Makefile b/devel/p5-Thread-Cancel/Makefile
new file mode 100644
index 000000000000..cf0669990910
--- /dev/null
+++ b/devel/p5-Thread-Cancel/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Thread-Cancel
+# Date created: 2007-03-18
+# Whom: Ruben van Staveren
+#
+# $FreeBSD$
+#
+
+PORTNAME= Thread-Cancel
+PORTVERSION= 1.09
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Thread
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ruben@verweg.com
+COMMENT= Cancel (i.e., kill) threads
+
+RUN_DEPENDS= p5-threads>=1.34:${PORTSDIR}/devel/p5-threads
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Thread::Cancel.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 then try again
+.endif
+
+pre-everything::
+ @${ECHO_MSG} "--------------------------------------------------------"
+ @${ECHO_MSG} "This module requires a threaded perl. If your install"
+ @${ECHO_MSG} "is not threaded please install lang/perl5.8 with threads"
+ @${ECHO_MSG} "--------------------------------------------------------"
+
+.include <bsd.port.post.mk>