aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Thread-Cancel
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-01-12 19:52:07 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-01-12 19:52:07 +0000
commit8489fe22d333952f1ac899f5b051868bfc391990 (patch)
tree3029f86f9e46723e7bc39e602ccece541e45f41b /devel/p5-Thread-Cancel
parent6199e7562db40beff5a2def1f84167b96e94e6bc (diff)
downloadports-8489fe22d333952f1ac899f5b051868bfc391990.tar.gz
ports-8489fe22d333952f1ac899f5b051868bfc391990.zip
Notes
Diffstat (limited to 'devel/p5-Thread-Cancel')
-rw-r--r--devel/p5-Thread-Cancel/Makefile37
-rw-r--r--devel/p5-Thread-Cancel/distinfo3
-rw-r--r--devel/p5-Thread-Cancel/pkg-descr11
-rw-r--r--devel/p5-Thread-Cancel/pkg-plist7
4 files changed, 58 insertions, 0 deletions
diff --git a/devel/p5-Thread-Cancel/Makefile b/devel/p5-Thread-Cancel/Makefile
new file mode 100644
index 000000000000..cf0669990910
--- /dev/null
+++ b/devel/p5-Thread-Cancel/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Thread-Cancel
+# Date created: 2007-03-18
+# Whom: Ruben van Staveren
+#
+# $FreeBSD$
+#
+
+PORTNAME= Thread-Cancel
+PORTVERSION= 1.09
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Thread
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ruben@verweg.com
+COMMENT= Cancel (i.e., kill) threads
+
+RUN_DEPENDS= p5-threads>=1.34:${PORTSDIR}/devel/p5-threads
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Thread::Cancel.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 then try again
+.endif
+
+pre-everything::
+ @${ECHO_MSG} "--------------------------------------------------------"
+ @${ECHO_MSG} "This module requires a threaded perl. If your install"
+ @${ECHO_MSG} "is not threaded please install lang/perl5.8 with threads"
+ @${ECHO_MSG} "--------------------------------------------------------"
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Thread-Cancel/distinfo b/devel/p5-Thread-Cancel/distinfo
new file mode 100644
index 000000000000..749cdedfa464
--- /dev/null
+++ b/devel/p5-Thread-Cancel/distinfo
@@ -0,0 +1,3 @@
+MD5 (Thread-Cancel-1.09.tar.gz) = b0e646d0051c6399628a846884dfcda1
+SHA256 (Thread-Cancel-1.09.tar.gz) = e8e899d2260b2bd8927f55ad5c8547718fa34c1e985bcc89d4979e137f63d866
+SIZE (Thread-Cancel-1.09.tar.gz) = 5492
diff --git a/devel/p5-Thread-Cancel/pkg-descr b/devel/p5-Thread-Cancel/pkg-descr
new file mode 100644
index 000000000000..1d57b8e5a7f3
--- /dev/null
+++ b/devel/p5-Thread-Cancel/pkg-descr
@@ -0,0 +1,11 @@
+This module adds cancellation capabilities for threads. Cancelled threads are
+terminated using threads->exit(). The thread is then detached, and hence
+automatically cleaned up.
+
+Threads that are suspended using Thread::Suspend do not need to be resumed in
+order to be cancelled.
+
+It is possible for a thread to cancel itself.
+
+
+WWW: http://search.cpan.org/dist/Thread-Cancel/
diff --git a/devel/p5-Thread-Cancel/pkg-plist b/devel/p5-Thread-Cancel/pkg-plist
new file mode 100644
index 000000000000..25db8067794c
--- /dev/null
+++ b/devel/p5-Thread-Cancel/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Thread/Cancel.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Thread/Cancel/.packlist
+@dirrmtry %%SITE_PERL%%/Thread/Cancel
+@dirrmtry %%SITE_PERL%%/Thread
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Thread/Cancel
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Thread