aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Tie-FileLRUCache/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2005-09-15 02:19:25 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2005-09-15 02:19:25 +0000
commit43be9606a19798aa1929ab25e9dd1ec7945ab96c (patch)
tree158faf854543e59625cc47eca035b3ebed98c691 /devel/p5-Tie-FileLRUCache/Makefile
parent9f8d18db8270cd7bb32d58b2e552a200d7fb1ee9 (diff)
Notes
Diffstat (limited to 'devel/p5-Tie-FileLRUCache/Makefile')
-rw-r--r--devel/p5-Tie-FileLRUCache/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/devel/p5-Tie-FileLRUCache/Makefile b/devel/p5-Tie-FileLRUCache/Makefile
index 5249f07e39a2..ae01501714ac 100644
--- a/devel/p5-Tie-FileLRUCache/Makefile
+++ b/devel/p5-Tie-FileLRUCache/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Tie-FileLRUCache
-PORTVERSION= 1.01
+PORTVERSION= 1.04
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Tie
@@ -16,6 +16,7 @@ MAINTAINER= clsung@FreeBSD.org
COMMENT= A lightweight but robust filesystem based persistent LRU cache
BUILD_DEPENDS= ${SITE_PERL}/Class/NamedParms.pm:${PORTSDIR}/devel/p5-Class-NamedParms \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
${SITE_PERL}/Class/ParmList.pm:${PORTSDIR}/devel/p5-Class-ParmList
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -23,4 +24,13 @@ PERL_CONFIGURE= yes
MAN3= Tie::FileLRUCache.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+.endif
+
+.include <bsd.port.post.mk>