aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Tie-Hash-TwoWay
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-11-15 08:51:38 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-11-15 08:51:38 +0000
commitc53ee976abb6fb681f09dac5d0af26fb828a01e3 (patch)
tree9468cc4abbca8c392d97f8d14733a80a61c7fa64 /devel/p5-Tie-Hash-TwoWay
parentcec454bcbc4ac918d931cd863cfc4146a25dea97 (diff)
downloadports-c53ee976abb6fb681f09dac5d0af26fb828a01e3.tar.gz
ports-c53ee976abb6fb681f09dac5d0af26fb828a01e3.zip
Notes
Diffstat (limited to 'devel/p5-Tie-Hash-TwoWay')
-rw-r--r--devel/p5-Tie-Hash-TwoWay/Makefile28
-rw-r--r--devel/p5-Tie-Hash-TwoWay/distinfo3
-rw-r--r--devel/p5-Tie-Hash-TwoWay/pkg-descr9
-rw-r--r--devel/p5-Tie-Hash-TwoWay/pkg-plist7
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/p5-Tie-Hash-TwoWay/Makefile b/devel/p5-Tie-Hash-TwoWay/Makefile
new file mode 100644
index 000000000000..32e8bc2896de
--- /dev/null
+++ b/devel/p5-Tie-Hash-TwoWay/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: devel/p5-Tie-Hash-TwoWay
+# Date created: 15 November 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tie-Hash-TwoWay
+PORTVERSION= 1.08
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tie
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Tie::Hash::TwoWay - two-way mapping between disjoint sets
+
+PERL_CONFIGURE= yes
+
+MAN3= Tie::Hash::TwoWay.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Tie-Hash-TwoWay/distinfo b/devel/p5-Tie-Hash-TwoWay/distinfo
new file mode 100644
index 000000000000..e15dfcff423c
--- /dev/null
+++ b/devel/p5-Tie-Hash-TwoWay/distinfo
@@ -0,0 +1,3 @@
+MD5 (Tie-Hash-TwoWay-1.08.tar.gz) = 969bca1d7d16956109f326a12ddfeef4
+SHA256 (Tie-Hash-TwoWay-1.08.tar.gz) = 1424ab8a1dee1431bd17f14c02cb734542680f5b2e5c04e26c76f3880116ba6b
+SIZE (Tie-Hash-TwoWay-1.08.tar.gz) = 3390
diff --git a/devel/p5-Tie-Hash-TwoWay/pkg-descr b/devel/p5-Tie-Hash-TwoWay/pkg-descr
new file mode 100644
index 000000000000..ad55200fea8b
--- /dev/null
+++ b/devel/p5-Tie-Hash-TwoWay/pkg-descr
@@ -0,0 +1,9 @@
+Tie::Hash::TwoWay will take a list of one-way associations and
+transparently create their reverse. For instance, say you have a list
+of machines, and a list of classes that each machine belongs to.
+Tie::Hash::TwoWay will take the machines, one by one, with an associated
+array reference of class names, and build the reverse mapping of classes
+to machines. All the mappings are stored as hashes. You can access the
+secondary mappings as if they were hash keys in their own right.
+
+WWW: http://search.cpan.org/dist/Tie-Hash-TwoWay/
diff --git a/devel/p5-Tie-Hash-TwoWay/pkg-plist b/devel/p5-Tie-Hash-TwoWay/pkg-plist
new file mode 100644
index 000000000000..1fd154af97e6
--- /dev/null
+++ b/devel/p5-Tie-Hash-TwoWay/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Tie/Hash/TwoWay.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie/Hash/TwoWay/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie/Hash/TwoWay 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie/Hash 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tie 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Tie/Hash 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Tie 2>/dev/null || true