aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Time-Clock
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-07-01 06:11:08 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-07-01 06:11:08 +0000
commita126ea0fed6838d0bc1e5d0cf9ad7beaec91f766 (patch)
tree471245d4ab02aa8c3251f879d3e27bf5da4da60a /devel/p5-Time-Clock
parent73ecc731926e01a4bf24a9bf44ba6b5603c28bd4 (diff)
Notes
Diffstat (limited to 'devel/p5-Time-Clock')
-rw-r--r--devel/p5-Time-Clock/Makefile28
-rw-r--r--devel/p5-Time-Clock/distinfo3
-rw-r--r--devel/p5-Time-Clock/pkg-descr6
-rw-r--r--devel/p5-Time-Clock/pkg-plist5
4 files changed, 42 insertions, 0 deletions
diff --git a/devel/p5-Time-Clock/Makefile b/devel/p5-Time-Clock/Makefile
new file mode 100644
index 000000000000..fc48ad29a8e9
--- /dev/null
+++ b/devel/p5-Time-Clock/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: devel/p5-Time-Clock
+# Date created: 30 June 2006
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Time-Clock
+PORTVERSION= 0.10
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Time
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= Twenty-four hour clock objects with nanosecond precision
+
+PERL_CONFIGURE= yes
+
+MAN3= Time::Clock.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Time-Clock/distinfo b/devel/p5-Time-Clock/distinfo
new file mode 100644
index 000000000000..b6c300fe1cce
--- /dev/null
+++ b/devel/p5-Time-Clock/distinfo
@@ -0,0 +1,3 @@
+MD5 (Time-Clock-0.10.tar.gz) = 798ae0ed9c62dc9b032c3947a46d59aa
+SHA256 (Time-Clock-0.10.tar.gz) = 5a41ac557d9fbf3694d2d828ee92a4a77087ad660ca3b209909159cfc7528bdb
+SIZE (Time-Clock-0.10.tar.gz) = 7597
diff --git a/devel/p5-Time-Clock/pkg-descr b/devel/p5-Time-Clock/pkg-descr
new file mode 100644
index 000000000000..2ef1cd675c2a
--- /dev/null
+++ b/devel/p5-Time-Clock/pkg-descr
@@ -0,0 +1,6 @@
+A Time::Clock object is a twenty-four hour clock with nanosecond precision
+and wrap-around. It is a clock only; it has absolutely no concept of dates.
+Vagaries of date/time such as leap seconds and daylight savings time are
+unsupported.
+
+WWW: http://search.cpan.org/dist/Time-Clock/
diff --git a/devel/p5-Time-Clock/pkg-plist b/devel/p5-Time-Clock/pkg-plist
new file mode 100644
index 000000000000..28068b999ff9
--- /dev/null
+++ b/devel/p5-Time-Clock/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Time/Clock.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Time/Clock/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Time/Clock
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Time
+@dirrmtry %%SITE_PERL%%/Time