aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Time-Duration-Parse
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-19 01:08:19 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-19 01:08:19 +0000
commitf7e724f6bb5b559de7697249574bcf50ccfb85d4 (patch)
tree89f89931ef028bd20dbc5293c0f31429022759c0 /devel/p5-Time-Duration-Parse
parent117d600017e28b65f51af59d5d00696e1722570e (diff)
downloadports-f7e724f6bb5b559de7697249574bcf50ccfb85d4.tar.gz
ports-f7e724f6bb5b559de7697249574bcf50ccfb85d4.zip
Notes
Diffstat (limited to 'devel/p5-Time-Duration-Parse')
-rw-r--r--devel/p5-Time-Duration-Parse/Makefile30
-rw-r--r--devel/p5-Time-Duration-Parse/distinfo3
-rw-r--r--devel/p5-Time-Duration-Parse/pkg-descr13
-rw-r--r--devel/p5-Time-Duration-Parse/pkg-plist8
4 files changed, 54 insertions, 0 deletions
diff --git a/devel/p5-Time-Duration-Parse/Makefile b/devel/p5-Time-Duration-Parse/Makefile
new file mode 100644
index 000000000000..a6b0d684cb87
--- /dev/null
+++ b/devel/p5-Time-Duration-Parse/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Time-Duration-Parse
+# Date created: 2006-07-18
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Time-Duration-Parse
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Time
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Parse string that represents time duration
+
+RUN_DEPENDS= ${SITE_PERL}/Exporter/Lite.pm:${PORTSDIR}/devel/p5-Exporter-Lite
+
+PERL_CONFIGURE= yes
+
+MAN3= Time::Duration::Parse.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Time-Duration-Parse/distinfo b/devel/p5-Time-Duration-Parse/distinfo
new file mode 100644
index 000000000000..a99940268e21
--- /dev/null
+++ b/devel/p5-Time-Duration-Parse/distinfo
@@ -0,0 +1,3 @@
+MD5 (Time-Duration-Parse-0.02.tar.gz) = 56e1c1674a5180d32927a130fd739d96
+SHA256 (Time-Duration-Parse-0.02.tar.gz) = 620fcf34768ee636beeb6600d966f272ac10a92907f0dae384f9ae32275bdf5a
+SIZE (Time-Duration-Parse-0.02.tar.gz) = 17725
diff --git a/devel/p5-Time-Duration-Parse/pkg-descr b/devel/p5-Time-Duration-Parse/pkg-descr
new file mode 100644
index 000000000000..87ea105296ae
--- /dev/null
+++ b/devel/p5-Time-Duration-Parse/pkg-descr
@@ -0,0 +1,13 @@
+Time::Duration::Parse is a module to parse human readable duration
+strings like 2 minutes and 3 seconds to seconds.
+
+It does the opposite of duration_exact function in Time::Duration and
+is roundtrip safe. So, the following is always true.
+
+ use Time::Duration::Parse;
+ use Time::Duration;
+
+ my $seconds = int rand 100000;
+ is( parse_duration(duration_exact($seconds)), $seconds );
+
+WWW: http://search.cpan.org/dist/Time-Duration-Parse/
diff --git a/devel/p5-Time-Duration-Parse/pkg-plist b/devel/p5-Time-Duration-Parse/pkg-plist
new file mode 100644
index 000000000000..2287f607713f
--- /dev/null
+++ b/devel/p5-Time-Duration-Parse/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Time/Duration/Parse/.packlist
+%%SITE_PERL%%/Time/Duration/Parse.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Time/Duration/Parse
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Time/Duration
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Time
+@dirrmtry %%SITE_PERL%%/Time/Duration
+@dirrmtry %%SITE_PERL%%/Time